Establishing the ILS on the PMDG 737

After days of watching videos and following checklists (thanks especially to British Avgeek), I finally completed my first full flight on the PMDG 737-700. It is a great addition to MSFS. However, the end of my flight from EGSS to EDDM did not go quite as planned. Via Simbrief, I planned an ILS arrival on Runway 8R at EDDM. Turning final at the specified altitude of 5000 feet, I activated the VOR/LOC button and was rewarded with ILS recognition, but as I approached the landing, I was unable to capture the ILS once I had activated the APP. Instead, the vertical bug, which had appeared considerably above me at 5000 feet, stayed at the same level above my horizon until I reached touchdown (once I realized the problem, I landed the plane manually). I have no idea whether the problem I encountered had to do with the simulator or the 737.

Has anyone had a similar problem (at any airport) or know if I missed a step in the ILS landing procedure?

1 Like

negative I am doing one flight a day with the 737 and have not had any problems. Perhaps the problem may be the airport.

This is the same thing I am experiencing. It’s frustrating to say the least. VOR/LOC no problem, soon as I hit the APP button, nothing. The plane keeps flying straight. No glideslope. I was wondering if I was doing something wrong, but I’m not. Also, I’ve been testing at different airports, it’s all the same!

Since my original post, I have managed to accomplish several ILS arrivals at airports other than EDDM with flawless G/S capture. That led me to conclude that the problem was airport specific. I guess not. Will report here if I run into the problem again.

Still the same for me!

I have had ILS capture problems at several airports. Last was 22R at KJFK. Instead of capture the aircraft continues to turn left and does a 360 at 3000’ at CORVT. It will continue at the same altitude but with tighter circles and bank angles if you allow it. The ILS will not capture during a Manual landing. I have checked my settings and instillation and believe the problem is a bug.

I believe the problem is caused by a conflict with AI Traffic.

Interesting. How did you come up with this surmise?

I fly the 737 regularly and have difficulties establishing the ILS on some occasions especially if there is a lot of AI traffic. I also have trouble maintaining the ILS heading after capture if there is some variation in the normal approach. i.e. ATC gives me a similar heading, but not the same as the ILS prior to capture. All this is variable but the conflict with the AI traffic is the most consistent. The aircraft flies well but there is inconsistency in approaches. Not sure whose problem it is, the 737 or me? Over the years I have flown the PMDG 737 in FSX and the ZIBO 737 in X-Plane and I feel confident in my ability to manage the MSFS 2020 version.