F-18 vapor, trails, and visual fx massive fps drop

Updated MSFS ( 2022-06-23 ), Nvidia RTX 3060 with latest drivers and the FPS drop is still there.

Tried the HPET disabling and it seems this fixed this problem for me.

Still a major issue for me here too - Maverick challenges (and the F18 itself) are totally unusable. 60fps to single digit frames when ‘vaping’.

Since SU10, textures at Miramar are the pink squares of death, and the F18 is pinned at full backstick the whole time :roll_eyes:

Yeah, I can only recommend following the tip above, except I made a backup copy of the library file and removed the grey lines completely. When I only commented them out I got a CTD on loading the sim every time.

After that no more FPS issues.

Brill.
Only just came across this post.
I have been having this problem since SU10 beta 1.27.18 never having experienced it before.
Any aircraft that produces a vapour trail was unflyable…in my case I have the F-14,15,16,and 18.
I have an all AMD rig, Ryzen 5800x 3d and a 6900xt, which gives me great performance…normally.

I backed up the 3 files mentioned above and then deleted them all from the \fs-base-effects\VisualEffectLibs\Asobo\Base folder and no more FPS crash or stuttering when pulling a bit of G.

Although this problem has only appeared recently for me it appears to have affected others for quite some time so surely Asobo has had the time to fix such an aggravating bug.

Thanks for this workaround…see you back at the Mach loop?

So thanks…back to the Mach loop for me

Wow… just did that fix running the two commands below (and reboot) to disable the HPET and it worked!!

bcdedit /deletevalue useplatformclock
bcdedit /set disabledynamictick yes

I don’t think Asobo realises what a serious bug this is - the sim is completely unusable with it. I couldn’t even get the flight stick to control the plane when the bug is there… pushing forward and back barely moved the aircraft and entire thing felt like it was in slow motion. Was getting 15FPS and 50W GPU power when turning. Now getting over 100FPS and GPU power staying at over 260W (using test desktop Fullscreen view only with DLSS off, DX11, HDR10 on and Medium settings and 2560x1440 on machine - 5950X/Aorus 3070/Hero VIII X570)

1 Like

New update same problem, need to remove this effects again.

Hi, I noticed that this thread was marked with the Feedback Logged tag back in June and then it was fixed for a few months but was reintroduced in Sim Update 11. Should a new thread be created when a previous bug is reappears? Would hate for this bug to go unnoticed because they thought it was fixed already.

Unfortunately we have not been able to reproduce this issue yet. No need to create a new thread - but any further details that may help the test team get the vapor trails in a state as described would be helpful!

1 Like

I’m on a 4080 + 5800x3D + 64 RAM and currently experiencing this. It grinds my system to a complete STOP.

I’ve had this problem for a long time too. Every jet that creates these effects degrades my performance greatly!
My system: AMD 5800X3D, RTX 3090, 32GB Ram.
Reinstalling, changing the CPU, replacing the RAM and the tips above didn’t solve the problem.
Only deleting the file for the contrails brings something.

1 Like

Not sure how helpful it is but there is another thread about this issue in the Sim Update 11 Beta forums that was closed once the Beta wrapped up.

https://forums.flightsimulator.com/t/the-f-18s-vfx-are-causing-lag-again/549350

Basically, anytime visual effects (wingtip vortices, high g vapor, water ripples while flying low above the water at mach 1+ etc) for the F-18 are triggered, in-game performance is drastically reduced.

Thank you for looking into this.

1 Like

Thank you! I’ve sent off more details for another repro attempt. Appreciate your help!

1 Like

It’s about all jets using this stock effects, without them game is smooth.

not sure if i need to open another topic on this issue, but i’m starting here…
i just noticed yesterday that vapor trails look like “airframe” coming from the aircraft, then just blends into the clouds or terrain. i went through all of the ridiculous steps before and after updating, and i havent changed any settings. it’s not the aircraft. ive tried several. anyone else seeing this? im sending a pic with the weather cleared, and it can be seen easier over water.

Smoke from 747 wheels will drop fpses from 60 to 35 for me too. There should be some slider to turn off smoke effects quality. Anynody know how this effect is called to turn this off in files?