F-35 PFD broken in 1.27.13.0

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

with the new beta update the PFD in the aircraft no longer displays dynamic numbers in most fields.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

start a flight with the aircraft

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

This is Dino from IndiaFoxtEcho.
After looking into the problem, it looks like 1.27.13.0 NANO VG XML text renderer does not work as the previous iteration.

PROBLEM:
Customers report that F-35 Primary Control Display has missing text in 1.27.13.0.

BACKGROUND:

  • The F-35 Primary Control Display (PCD) is programmed in XML
  • The F-35 PCD uses custom fonts: they were OTF fonts until 1.0.9 and then we switched to TTF in 1.1.1 (following decision from Microsoft to use NANO VG as standard rendered of XML gauges, and given that OTF do not work with NANO VG). Some of the capition are bitmap.

ANALYSIS:
OTF fonts (rendered with generic fonts) seem not to render at all in 1.27.13.0 causing most past of the screens to be blank.

SOLUTION:
We expect that F-35 1.1.1 works as intended: starting frmo 1.1.0 we have removed OTF fonts and replaced them with TTF ones. Users should make sure that the older version of package is properly deleted before installing the new one.

Another solution is to temporarily disable NANO VG in the EXPERIMENTAL menu.

3 Likes

Hi Dino, I’m running SU9 on the Xbox. I received F-35 version 1.10.12 today.

The aircraft can catch the glide slope and bring me down for ILS landing if I keep my airspeed at 250 KTS but not below that.

ATC is telling me to keep my air speed not above 210 KTS for ILS landing. When I follow ATC’s guidelines and enter 210 in the Speed Hold box in autopilot on the PCD, the aircraft nose dives, Altitude Hold mode remains active. It is shown in white text.

Reinstalling the file did not produce results. This wasn’t an issue with the previous version of the F-35

Good day - please contact us directly via Facebook or via email. This post is for SIM UPDATE 10 BETA feedback only. Apologies for being so rigid, but it I think it is important we keep the discussion on topic to get a better sim.