F/A-18 Throttle issue with honeycomb bravo [SOLVED]

Microsoft store version
Non developers mode

Hey folks, I’ve been unable to use the F-18 since the SU7 first arrived. It seems everything with the throttle works correctly on the ground with my honeycomg bravo in a 2 engine jet config that works perfect with the MB-335, CJ4 etc. Just after take off I loose all throttle response. It seems to be in a sort of auto throttle mode but I do not have it enabled. I’ve tried disabling it by pressing the button on the throttle but this has no effect. I do have all assists turned off and everything is set to hard in the settings. I’ve tried assigning an auto throttle toggle to a button on my yoke but this also has no effect. Does anyone have any suggestions as to what it may be?

Turn off any airspeed hold buttons and dials on your Bravo.

You also may want to check if your AI settings are not causing the issue. With SU7 most AI settings have been reset to default values.
Options → Assistance Options → Expand the Piloting section and check if Assisted Take Off, Assisted Landing are disabled.

Thanks for the reply guys. It was my Bravo autopilot settings after all. Sorted now thankfully :slight_smile:

Closing as OP seems to have resolved the issue.