Failed purchase in Marketplace - Money Deducted from Account - Steam Version

I just tried to buy the Deluxe Premium version and everything went well on the Stem side. When I closed the transaction by authorizing it and went back to the game, I was confronted with this:
image

I went to my e-banking to check if the purchase had been registered, and yes it was:
image

Where can I get my upgrade? In the sim it is not available.

I think you have to covert the steam money into Microsoft flight sim credits and then the game should load. I bought a plane and thought the money was gone but found some where that you had to click on a link and the plane loaded and all was fine. Please dont ask me how and where because I found it in steam somewhere but cant remember where. hope this helps Im sure someone will have this info for you. cheers Mike

1 Like

Steam does convert the money into FS credits, I got 340. Did all the steps in Steam including the last authorizing. When I got back to the sim, it just said “purchase failed”.

No, you shouldn’t accept that the money is gone. Raise a ticket, reach out to MSFS support. They will help - other people have had this issue as well and it’s been sorted out.

1 Like

Thanks, I have raised a ticket. But not thanks to the mods here. I had to find it out by myself.

I had the same thing happen to me a couple of days ago, after a reboot the plane downloaded again, i have a feeling its a server issue … hope you get it sorted soon, very frustrating …

All issues with purchasing needs to go Zendesk.

https://flightsimulator.zendesk.com/hc/en-us/search?utf8=âś“&query=Purchase+failed+&commit=Search

Steam users must have enabled the Steam overlay, for flightsim otherwise it will not work.

1 Like

I had a similar issue at the start of the year and raised the question with Zendesk and Steam why there is no proof of purchase receipt provided.

Steam point out that from there side they actually do provide a receipt for game credits bought but that all transactions after that are entirely out of their hands.

MSFS2020 Zendesk suggested making a personal list of all marketplace purchases but when asked whether they would accept such a user created list as proof of purchase admitted that they would not.

It’s was at this point that I decided the Marketplace was not fit for purpose and stopped using it.

1 Like

Yes, I have it enabled, that’s why Steam deducted the money and converted it to 340 credits. The last step I did was to authorize the purchase in Steam. When I got back to the sim, it told me “puchase failed” for some inexplicable reason.

ok, so you have the Steam overlay enabled. When you clicked on the purchase in MSFS, did you then ALT+TAB out to the Steam Overlay to complete the purchase?

The purchase is completed in Steam. Credits (340) were added to and deducted from my wallet, and I authorized the transaction as the last step.

The overlay pops up automatically when I click on “buy and download” in the sim

Just to rule out user stupidity, I tried purchasing another item with a different (proper credit card) card. The same result. In Steam the transaction is complete, the sim just notifies “purchase failed”:
image

I had the same issue as you…twice. You make the purchase in the sim and you have to ALT+TAB out to the Steam Overlay to complete the purchase.

When making the purchase, after clicking on BUY in MSFS, have you ALT+TAB out to the Steam Overlay?

When I click on “Buy and download” in the sim, the overlay pops up automatically

Now I am totally confused. The item I used as an example above now for some inexplicable reason is purchased? I never completed the transaction in Steam, did not add any fund to my wallet there, and most certainly never authorized any transaction regarding it:

image

And it is installed…

image

Not sure here, I’m guessing that your previous attempted purchase actually added Flightsim Credits which this test purchase then used.

If you don’t want this airfield I’d suggest requesting a refund from MSFS… Once you have those funds back as Flightsim Credits try your original chose again.

I looked at the marketplace to see if there was anything that I wanted to buy and there was nothing that I could bring myself to buy even as a test purchase…

Most of the items I’ve bought are direct and not through the marketplace.

Third time’s a charm, as they say… unfortunately not, this is happening with every purchase I complete in Steam:

image

I’d recommend waiting a few days before buying stuff - at least let support get back to you. There’s clearly something wrong and you don’t want to end up spending a ton of cash for no reason.

Probably a server issue

Most likely :grin:

still waiting here… the ZD is really not the fastest crew.