FBW A320 MCDU on Tablet

For months I have been using the remote control of the MCDU on my tablet (Chrome Browser) without problems. It has stopped connecting for some reason . I changed nothing. When I start the server I get the statement “Waiting for Simulator”. The simulator is already running and powered up so what does this mean. I have Port 8125 set in the EFB as per FBW instruction. Any help would be appreciated.

You might be better off asking this on their discord channel.

Moved to #third-party-addon-discussion:aircraft

Tried to join up with the Discord but it tells me I have a badly formed email address. Thats the one I have been using for 10 years without problem. Something wrong with their software! It started sending me around in circles and we all know what can happen doing that.

1 Like

Just to confirm with you. I just finished a flight about an hour ago having updated to the latest development version and had no issues with the MCDU on a tablet using chrome browser and port 8125.
So I think it’s unlikely it’s been broken by the FBW team.
Has anything recently changed your firewall settings? You could try disabling it for a few seconds just to test.

Also make sure that in the FlyPad it’s set to ‘Auto ON’

1 Like

Thanks guys for your help. I do have the EFP section switched to Auto On. Been going around in circles all afternoon so called a halt to procedings as my brain was getting fuddled. Will take up the problem again tomorrow. I did delete and reinstall completely the A320 just to make sure nothing corrupted there. I am using the Experimental version, I wonder if that might be the culprit, I think I will go back to the Developement version.

Sorry to hear that the suggestions so far did not help… Fwiw, I’m using the experimental version for a while now and I never had that issue, so going back to dev probably won’t fix it either. But I guess still worth a try…

Same thing happen to me. For me it was my firewall. I updated mcafeee which then put a firewall up. I found the server exe in the firewall blocked list and gave it permission to go past firewall and all good. So… first you can do is turn off your firewall, if you have one, and then see if you connect.

Tried with firewall turned off and same results. Tried to follow FBW instructions to change port as the server tells me that 8125 is occupied but in CMD it with not accept the FBW line to change the port. I have just about given up for now and will wait for the Fenix Airbus to be released to continue flying.

I just restarted MSFS and now Isee the MCDU on my tablet but the screen is blank. In the aircraft the screen is filled as normal.

???

As a follow up I have now got the MCDU working on my tablet. I think it was something in the firewall although all I did was repeat the actions that I had done the day before. That was to allow access through ports 8125 and 8380.
What is strange is that in the EFB I have port 8380 but the server.exe window tells me to select 8125 on my tablet and that set up does work. If I change my tablet to 8380 it doesn’t work, or if I change the EFB to 8125 it doesn’t work
Is there any explanation for this?

1 Like

It helps me. Thx~

With todays experimental-update the folder “flybywire-aircraft-a320-neo\MCDU SERVER” is missing and also the file “server.exe”.

In the newest update “server.exe” is back, thank you.