Fenix A320 - EFB - iOS 9.5.3

I’m currently on the fence to purchase the Fenix A320 but I would love to know beforehand wether the EFB will work on my old iPad 2 or not. Is anyone either using an old iPad running iOS 9.5.3 or, maybe willing to test it for me? I know that the MCDU of the FBW for example doesn’t work because iOS version 9.5.3 isn’t supported but all the AviaCDUs do still work and it adds an amazing extra level of realism.

It makes sense for it not to work on such an old operating system but the AviaCDUs give me hope that it possibly could. At any rate, I wasn’t able to find any info on this topic so I’m hoping anyone here can shed some light on it.

Kind regards,


I just posted your question on their Discord, will let you know what they say.

I have an old first version iPad just need to track down a charger and I’ll give it a try for ya.

1 Like

Thank you! Curious to hear what the response is or, what your personal findings are.

Just got the first generation iPad booted and it certainly doesn’t work (iOS 5.1.1).

It loads, browser just can’t re-size / handle it.

Can’t seem to find any other browsers that will run on this iOS either.

Hmm that is interesting, the fact that it does somewhat load gives me hope that the resizing might be solved with iOS 9.5.3. When trying to open the FBW MCDU the page simply remains blank. Are there any buttons within reach that you can press to see if it reactes to commands or is that not possible? Or maybe change something in sim to see if the iPad mirrors that change? (Though I’m not sure if the EFB works in this manner with the Fenix)

Any reactions on their Discord?

Thanks again for taking the time to investigate this, much appreciated

1 Like

I worked with it for about a half hour trying to find some click spots, etc… but nothing was working (and actually crashed the browser a few times).

Nothing on Discord yet.

I have 2 more iPads currently connected to the sim but I forget which versions they are. Let me fire them up and check.


1 Like

A that is a shame.

Awesome, I look forward to the results.

Standing by!

I guess they are both newer and running



I tested on the 12.5.5 and it works like a charm.

A buddy I fly with just said he has a gen 2, let me confirm with him (he has Fenix as well).

1 Like

Fantastic! There is hope yet haha

Sorry bud, he just gave me the software versions and when I looked them up they were iPad mini 2, not gen 2, so much newer.

I’ll let you know if I hear anything on discord.

No problem man, I’m already happy the question is out there. I’m sure there will be an anwser sooner or later and you’ve already played a big part in making that happen so thanks again.

I’ll keep checking in here for an update

1 Like