First experience with VR and Reverb G2

So I just finished my first VR “flight” with my brand new HP Reverb G2s (they literally just arrived today, too), and my initial reaction is that I’m satisfied. I need to do some tweaking, but it’s the closest I’ve come to flying a real airplane since the last time I flew a real airplane.

Some observations:

  • Getting it setup was harder than I anticipated, and I’m still not sure I’ve got it right. I got them physically connected, and played around with the Mixed Reality portal, which seemed to work ok, but I obviously didn’t have the first clue what I was doing.
  • I got around to trying a flight, and that took a little voodoo. First I installed SteamVR, set it up to use beta code, and fired that up. It seemed to work to an extent, too. Maybe it worked perfectly, but with my total noob status to VR, I really don’t know what it was supposed to do.
  • I tried firing up FS2020 from that, but didn’t get it to work right. So I did some googling, and found out I needed to actually enter a flight, and hit CTRL-TAB to get it going, then the Spacebar to center. Neither worked.
  • I finally had to manually do the keyboard bindings in settings to what they needed to be, after lots of googling and frustrations, and finally it worked. Really cool!!!

The settings are set very low, by default, and the only change I made was AA to TAA. I haven’t got a clue what kind of fps I was getting (frankly, I don’t know how to figure that out in VR), but it was more than acceptable. Now I start turning up settings until it starts getting mad at me.

The one thing I would categorize as a problem is that I was was closer to the panel than I want to be, but I’m guessing that somewhere buried in a setting sub-sub-menu in either the sim or the WMR software (SteamVR just kicked me back to WMR when crunch time came), I’ll find a fix for that.


  • Modestly OCed 10600K
  • Very OCed 2070 Super
  • 64GB of CL16 RAM
  • 32" 1440p display. Not that it matters, but it was mirroring what I was seeing which was probably eating resources. Probably will help if I figure out how to turn that off.
  • And of course, HP Reverb G2s, with basically default software settings, except I changed the resolution in SteamVR (I think) to something closer to native. It’s on drugs with the options it presents.

Anyway, that’s my experience after one turn in the pattern in a 172 G1000 version. I’m gonna have to turn up the refresh rate on that, I never noticed it on my display, but in VR-world, I sure did.

But the update did break my beloved WT 0.8 CJ4 mod… :disappointed_relieved: But I have faith they’ll get that fixed pronto, if they haven’t already.


Glad to hear! I have a somewhat similar setup, but my G2 is delayed until February :frowning: On the positive side, I can read about your and other people’s teething problems and be prepared when that precious piece of hardware finally arrives :wink:

HP reverb does not require the use of SteamVR. It adds an additional layer of complexity and potentially well affect performance. You only need to use Windows Mixed Reality. I suggest you download the latest OpenXR developer tools from the Microsoft Store. Lookup the user @CptLucky8 and his guides on performance optimization. Very helpful and detailed.


G2 owner here as well and tried the OpenXR Dev tools Preview - seemed to be much smoother, enabling it to hit 30fps. Where was quite a lot of shimmering and artifcating in the cockpit though which was very distracting. I am running a RTX2080 with i9 9900k so 70% res scale with low/medium was best I got.

I am not sure you need the Preview version but it does seem to be the only version that you can force smoothing on. I cannot see any way to open the standard OpenXR for WMR app that gets installed as part of WMR to enable the smoothing?

Got it running to my satisfaction but have 1 issue. No matter what Key I bind to show the VR Toogle Toolbar it wont bring it up so I have no way to reply to ATC or anything else. Any ideas? Tried a keyboard bind and stick and throttle bind but none work. Bar that its a wonderful experience for me. Will turn on Dev mode to see the FPS but not having any issues so far in the a320 (with Mod) or a 172. Just need to figure out what is wrong this that menu toggle.

EDIT : OK turns out it was the mod to hide the toolbar from appearing at the top that was causing the issue for me so if you have that delete it from the Community folder.

I guess I need VR 101, because I have zero idea what you’re even talking about. I downloaded the OpenXR thing you mentioned, but I have no idea what, if anything, it did for me aside from putting a little red square with barely readable info in one of my eyes.

Good news is that I am an uber-dork-nerd, so one way or another, I’ll figure out what I’m doing. Maybe.

1 Like

Thanks for posting this. I just got an HP Reverb G2 (actually my wife won’t let me have it until Christmas) and was checking the forums for a good starting point to set up. This will help.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.