First thoughts on sim update 5

please man how do I change it? it is so annoying

Downloading was longer than usual, but it worthed the waiting…

Every settings at the max and the game is sooooo smooth; what they promised was finally delivered!

Wowwwwww!

1 Like

In the relesae notes:

Cockpit interactions

Added the new “Lock” interaction system:

  • Set active by default but can be reverted to “Legacy” in Options / General Options / Accessibility.
  • Tooltips are now displaying the instrument name, instrument values, and controls (dynamic depending of the device in use)
  • Using the cursor or the camera center pointer, you can highlight any interactive cockpit instrument.
  • Once highlighted, you can interact with the instrument:
    • If the instrument is simple (buttons, 2 positions switches), tapping Xbox Controller A or Mouse left button will interact with it.
      If the instrument is complex (knobs, levers…), tapping Xbox Controller A or holding Mouse left button will lock on it.
    • Once locked on an instrument, you can:
      • Use primary (Xbox Controller A/ Mouse left button), secondary (Xbox Controller X/ Mouse right button) or tertiary (Xbox Controller Y/ Mouse middle button) interactions.
      • Increase/ decrease the instrument (Xbox Controller LT/ RT or Mouse wheel)
      • Use gestures (Xbox Controller left stick or Mouse movements)
      • Unlock the instrument (Xbox Controller B or release Mouse left button)
6 Likes

You have to go in the settings and change it from Lock to legacy. That will revert the mouse interaction inside the cockpit back to the way it was before the update. It’s either under miscellaneous or accessibility. I’ll post a picture of it later on

General > Accessibility > Cockpit Interaction…change to Legacy

It doesn’t remove the dot cursor. Believe me, I tried that already.

2 Likes

That dot cursor is very annoying

3 Likes

So far … ugh. CTD with AI on.

First noticed walls missing at airports.

Then the “new” UI, great to find that while taking off … it’s pretty horrible.

Trim wheel I spent time on getting to work for me, COMPLETELY CHANGED and now broken.

Free-look hat switch, now works completely backward on the horizontal but not the vertical, no idea how to fix that?

Static sounds during load now worse with more added to flight, corresponds to pausing caused be changing views.

Pausing changing views and pausing during acrobatic maneuvers.

LOD is terrible, 14 miles from Boston with good visibility at 1100’ is more like Blobston.

Smoke effect is totally broken. OLD EDIT: smoke effect was caused by not updating awesome We Love VR mod which was totally on top of the update as amazing freeware!

basmk

I had high hopes and higher fears for this … the fear factor is real.

5 Likes

Given there is no smoke in the sim, you are running mods right? Try all this with an empty community folder.

EDIT: also did you do the world updtaes (probably fixes the LODs and missing walls at airports)

I would also like to point out that hovering over the throttle, propeller, or mixture control no longer tells you a percentage, even on Legacy mode. Which is also frustrating when you want to quickly adjust your aircraft based on those memorized percentage numbers.

3 Likes

This are my impressions, downloaded with 600mb in 2 hours… then excited! Removed all mods. CTD CTD CTD CTD CTD CTD CTD
I take my risk and install the CRJ and guess what?
CTD CTD CTD CTD CTD CTD CTD

And I never ever had a CTD in fs….
Great job…. Not

2 Likes

I fixed mine. Turns out although I was using Addons Linker, I had somehow installed rogue software directly into the Community folder. I removed that, and my flights are loading fine now. Of course now I need to go back and start loading in my must-haves to see what will work.

Turn off AI traffic

4 Likes

I’m really liking it so far. CPU usage is better and as a result I no longer get much stuttering in VR. There is indeed a bit of a pop-in effect sometimes when quickly looking in a different direction. I think it’s an acceptable trade-off for the much better performance I’m getting.

I noticed some some lightning in a mostly clear sky over Tokyo a moment ago, I’m a bit surprised this bug still hasn’t been fixed after all this time.

2 Likes

Never had it on due to IVAO and Vatsim…
All empty in community, rebuilt xml content…
Just not gonna waste more time, they will come with a patch at some point…

Saw this a couple of times this morning too. Restarted, tried again and download started ok.

Well after much messing around I got updated and jumped into the TBM9. Bearing in mind that I have just bought a Reverb G2 and not quite bedded it in properly this update seems mostly brilliant. Running smooth graphics at 100% render scale and detail where yesterday it was jerky. Using a 9700k and an OC 2080ti with 32gb.

Suspect this update will get a few fixes but generally the performance has taken a big step forward. The Naples (i Think) flight in the Cessna was a different level.

Brilliant and thanks to Asobo and MS - Are we quite there yet - no but a really good step forward.

Adrian

2 Likes

Server load is impacting experience right now definitely and probably causing some CTDs

1 Like

Oh no. I can take or leave the fps improvement, but was rather looking forward to see some realistic wakes behind float planes. Oh well, will take a look later.

No issues with downloading the updates.
And wow, performance has been vastly improved for me, particularly in photogrammetry areas like NYC. Places where i would normally get low to mid teens are in the high 30’s, generally hovering close to 40fps with a much improved and smoother flight.

So far so good, but i’ve only flown twice so far.