[FIXED] CTD Exception code 0xc0000005 Crash to Desktop

Really hope this can resolve at least a few of your guys issues. I couldn’t log a single flight since it started and have lost close to 20 hours from Crashing to Desktop in flight or when trying to exit to the menu.

FlightSimulator.exe had Exception code 0xc0000005 in Event Viewer as many have posted.

This is how I fixed it:

Nice video. Personally, I’ve disabled AI as well and it does make a difference.

I’ve added your fix to my list of performance related posts .

Also voted up your thread for the effort in your video :wink:

my game crashes befor i even get to the main menu of the game my pc have the min req for the game so is there a work around to disable this without going in to the game ?

I’m guessing that if you are crashing pre menu this may not be your issue. I didn’t have any issues until the flight loaded. I feel your pain.

I had did error twice as well. My solution was to increase the virtual memory to 10gb. I eventually just put 16gb min / 18gb max. (I’ve 16GB of Ram.)

Unfortunately neither disabling all traffic (AI was off to begin with) nor the updated driver seem to help me.

When I set BIKF on Iceland as starting location, the game crashes even while loading. At least I can check if anything helped by loading in at that airport.

I played around with the debug menu a bit and disabled all airport rendering. Then it loaded in just fine but the game crashed immediately after I enabled “draw on terrain”. Which makes me think that there is an issue with one of the game files.

1 Like

Flying near BIKF crashes the sim. It’s a known issue and Asobo is aware of it. I’d suggest using another airport to do your testing.

3 Likes

@StockGuide86977 Good to know. Will do my testing around different airports then.

Just remember that this process can be used to find “your” specific issue. AI Traffic was mine, another user messaged me yesterday and stated that for him it was V-Sync and that as soon as he turned it off he was no longer mainthread limited and went from 18fps to 50fps and no crashing.

1 Like

I already tried lots of things as suggested in the other thread. But since I tested crashing near the broken airport, I don’t know why my game crashes sometimes.

Had this same CTD problem. Crashing 100% of the time, but was on the main loading screen (the one with the TBM departing KSFO, just after “Press Any Key”). Checked event viewer and showed an exception code of 0xc0000005. I pulled everything out of my Community folder, as I had been working on some liveries. After doing that, sim started just fine. Will report back if anything changes, but that solved it for me.

I tried that and it helped a little, however I still experience crashes during the approach.

Turning off AI did not work for me. What worked for me a combbination of the following.

  1. Turning off all active programs like iCUE, Nvidia geforce experience and Razer Synapse before starting the sim
  2. After the sim has loaded fully till menu, disable explorer.exe from taskbar
  3. Turn off Vsync.

Am on work trip and wil beb home only tomorrow and will check activating one by one the above and try to narrow it down. But doing all those above was the only way i have been abble to complete my flights even from LFPG to EHAM

Most likely the fault lies in the sim, not in virtual memory, Nvidia software, etc.

Yesterday i was having CTDs and today i’m not. This isn’t because i used different toothpaste today but more likely because a bug was triggered by a trigger from within the sim like more multiplayer traffic, weather situation, settings, location, etc. and today the circumstances are slightly different. Maybe you removed GeForce Experience in the mean time and now you believe that was the solution. That’s superstition.

2 Likes

It’s pretty foolish and stupid to come out with comments like those without actually knowing the background details. Everyone is facing a different set of troubles and being solved with different solutions as it’s become obvious by reading the posts. What is happening to you is not reciprocated to everyone else

Only Asobo can bring solutions. If the program crashes this is not because a virtual memory setting or software like Razer Synapse. It’s just not how it works, these programs are isolated in memory and won’t crash each other.

CTDs can drive you crazy and people will try everything and think they solved it by changing settings or closed programs when in fact the problem just went away by itself because of some other reason. It’s likely weather or location related or other variables that change all the time. Closing Nvidia Experience is very unlikely to be a solution of MSFS being unstable.

You got that right. It did get me go crazy. Had a working alpha 2-5 and since beta I had 100% ctd midflight. After final release things were same. Tried everything till I got to this above mentioned combo. Have a few days of solid end to end flights. Say what you may but this worked for me at least till they release a patch. So no need to patronize as you do not know everyone situation.

Hope they fix this I looked at my event viewer I have tons of this code crashing my game since day 1 of launch 3 patches and still no fix you think they get it fixed by now but no lol but maybe in a year it will be smoother ugh till then happy flying

Since this always happens in the same area (which is usually different for each flight day) and i can fly error-free somewhere else, I guess it is more of a cache issue. Since it also happens when the rolling cache is switched off and the manual cache memory is unused, I think WE can’t do much about it.

Since an error code C0000005 (access violation error caused by a buffer overflow) is output, it is probably less about defective or too small RAM bars than about a programming error in which a command is missing as to how the program should react in such a case.

Since it always happens in the same area or airport, indicates a cache story. With the new update there were also handling “improvements” for the “manual cache” !?

The fact that the Smartcam became independent is really a mystery to me :eyes:

This exact error started to happen to me today. Coincidentally, I had just installed some liveries in the community addon folder. Sure enough, after I removed them the CTD disappeared completely.

Hope this helps someone having the same issue. I can live without liveries, I guess :frowning: