[FIXED] MSFS crashes to desktop now when I load BGL in Scenery Editor

This issue started all the sudden: if I load a project to Dev mode. All ok. If I load the Scenery BGL to the Scenery Editor, MSFS crashes to desktop.

It started doing this with all the projects I’ve been working on since a couple of weeks now. Not just one. Something happened to the load in scenery editor process.

I rebooted my PC but this did not fix this new and sudden issue.

Anyone had this?

Happened to me too after patch 5. I did have some scenery that was causing a CTD that I removed. I haven’t tried editing since. I would suggest removing everything from the Community folder temporarily, edit your project, and then move everything back. That is my plan for this weekend and see if it works.

I tried this and unfortunately not working.

In my case it did not start after a patch, I was editing today, all was fine and all the sudden.

I am wondering if the issue is related to a UI bug, the scenery editor window perhaps.

Even when I load the BGLs of the Sample projects in the SDK in the Scenery Editor, it crashes MSFS now.

So I just sent a detailed report to Zendesk about this issue.

I had this issue after patch 5 too.
After some research it turned out I needed to import my models again with the latest version of ModelConverter X. So if you used this program, it may be worth to check if this fixes your issue.

If not, the problem probably is elsewhere.

I used Blender Exporter and it works ok. Even after the patch all was working.

The last thing I did in one of my projects is adding text in the POI properties field called “owner”.

The SDK Sample projects as well as creating a new project with a new scenery BGL crashes the sim as well.

Something triggered a dev mode bug somehow. Perhaps related to something in the latest Patch as you mention but it was much later.

The issue seems fixed after reinstalling the SDK from the dev mode.

No luck on my end. I removed everything from the Community folder, reinstalled the SDK, and even tried a new project instead with no luck. As soon as I click open in scenery editor, CTD. Off to Zendesk…

This is worrying. I hope I will not get back to the issue after doing some more work on the projects.

I thought my SDK was outdated a notch this is why.

But here I see probably something else that made the loading process work in my case ummm.

I should add that I had an issue with Patch 6 getting stuck in a loop. I used the verify files trick on Steam that forced a re-download of everything. Once I downloaded and installed everything in the content manager, the problem doesn’t exist. My guess is that something didn’t get properly installed in Patch 5 that caused the editor CTD and the problem with Patch 6.

I have the same problem now with the SDK.
I had loaded the latest update, no BGL is built with exception the BGL for the delete shapefile.
I have tried to reinstall SDK nothing happens.


Since I reinstalled the previous SDK, I don’t have the issue anymore on my side here.

And last evening, I installed the latest 0.8 SDK and I could load scenery in the dev mode, edit , build etc and all was good.

Again, I wonder if the glitch was something else. I will try again and report if any crash to desktop happens again.