Flaps inoperable

Has anyone had an issue with flaps being inoperable? It happened last night after updating to the latest Nvidia driver, although I doubt there’s any correlation there.
I’ve tried restarting MSFS, loading various planes, tried operating the flaps by keyboard, mouse, and the assigned button on my throttle quadrant, but they still won’t work
Any help would be greatly appreciated.

Do they move at all, or do they snap back to the original position?
The only thing I can think off is the AI copilot (or any other assistance) unintenionally being turned on.

Sometimes video driver software overlays have conflicts with existing MSFS bindings. Check to see Nvidia driver isn’t using those Function-Number buttons for something else.

There’s a slight flick of the flaps lever and the red light on the panel when I press F8, but that’s all.
When I select AI to Control Aircraft the flaps will work, but not when I go back to manual control.
I’ve gone through all my settings but can’t seem to find anything that will give me back control of the flaps.

I also noticed that the heading bug now goes in 10 degree increments instead of one degree. This started happening at the same time as the problem with the flaps.

I went into Nvidia GeForce Experience settings and made sure ingame overlay was turned off but I still have no control of the flaps. I’m not sure if the could be other conflicts with it though.

Make sure your community folder is empty and try again. If it was just the flaps, I’d think control binding conflict, but when two things happen at once, I tend to think about addons.

My community folder is empty.

This is really strange. I hope I don’t have to reinstall the whole sim :confused:

I solved it!

It turned out the Xbox controller was causing a conflict. I unplugged it and have full control of the flaps and can now adjust the heading bug in 1 degree increments again.

It’s never caused a problem before, and I don’t know what happened to cause the problem now, but I can live without the Xbox controller as I rarely used the drone camera anyway.

I’m just happy I can fly again!

Thank you for your help :blush:

2 Likes

Since all your settings are cloud based I would delay reinstalling the sim as much as possible.

Have you tried disconnecting the hardware and to control the flaps and heading bug with the mouse?

edit: great that you have solved the problem :slight_smile:

Btw. My USB extension cable failed a few days ago…it took me hours to find that one out…

1 Like

On my xbox controller there’s a hidden analog-digital select switch.
It did happen a few times that I unintentionally moved it to digital… with weird results.

in case it’s happen againg =>

https://forums.flightsimulator.com/search?q=heading%20bug%20category:205

==>

e.g.

Well I hope this helps some people after all most through out my PC lol and tearing hair out I finally stumbled across what fixed my Flaps returning halfway, when I went full Flaps it returned to halfway position again

So I went to Assistance Options it was on “ALL ASSISTS” I changed it to TRUE-TO-LIFE and bang my flaps worked again

hoped this helps someone (A like would be good if it helped you)

I have a similar problem, I can no longer activate the spoilers manually. I tried to I tried with thrusmaster t.16000 and the keyboard, tried to reassign the commands but nothing works.

having same issue, I only can retract spoilers using keyboard binding, not extend them… any solution for this ???