Flight controls locked when using mouse look

Since SU5, you can no longer use the mouse free look and flight controls at the same time. This happens with all aircraft and with every set of peripherals i have tried - using legacy interaction mode.

Means you cannot manually fly the aircraft and look around at the same time.

Any way to resolve?

Yeah im having the same problem since SU5 came out

Yeah this is definitely a regression in SU5 :frowning:

Yes, same here - sort of glad it’s not just me! Hope it can be fixed.

Great find, I also noticed this. For me if i click the mouse wheel i can steer while looking around, however if i hold the right mouse button to look around, the controls are disabled.

So the workaround is to use toggle mouse look with wheel instead of holding down right mouse button.

2 Likes

Still having the issue after SU7. Asobo mentioned in q&a yesterday they believe this was solved and asked the community to report in forums if it isn’t - well, here is my report: it has not been fixed in SU7 for me.

Same here, still an issue. Just crashed on final due to this.

Have you tried to reset your mouse settings?

Having the same issue since months and can’t find many others having the same problems. I hope this problems gets addressed, because it sure needs a fix to be able to taxi and look around without having to risk your controls freezing in a certain position.

LMAO this is even more broken in SU8 -

now middle click toggle doesn’t work, it activates free look but doesn’t deactivate it. Blimey, what are these lads up to

I too still have this issue in SU8

Yip same problem here since I think update 4

This is the third thread on this subject. The main one reached almost 350 votes since sim update 5.
I think if we don’t disperse votes in double useless threads we might even make them notice us.

Same deactivation problem here. Only right click deactivates the freelook.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

When you hold right click to look around the cockpit, controls (roll/pitch/rudder) do not work. Bug has been in the sim for quite sometime and was supposed to be fixed in SU10.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Hold right click on the mouse and try using your controls.

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hey there, @Booms3220. This issue has been around since before SU10 Beta and is not a regression caused by the beta. I have not found anything about this in the SU10 Beta Release Notes.

I have moved your report to the regular Bug section where this has been discussed. You can vote on this here.

This was supposed to be fixed in SU10 as mentioned by Asobo in the last Dev Q&A

That may be true, but it is not listed anywhere in the release notes for the current beta build. They may add it in one of the next beta build updates, but that remains to be seen. I would also like to see this addressed :wink:

1 Like