Flight Training - VFR - First Solo Navigation not recording landing event

When completing the First Solo Navigation in the Flight Training - VFR Navigation, I get an error when landing in Sedona. The instructor tells me I wasn’t supposed to land there. I did it twice with the same issue. Anyone else experiencing this? Or am I way off?

This thread may be some help.

Thanks! I tried again and I think the training hadn’t initialized properly, the first two times it didn’t show me the objectives, but this time it did.

1 Like

Great! Glad it worked out in the end. On to the Airbus now…

Thanks! Excited about the Airbus but I’m struggling with the landing. I don’t get how to maintain the 3 degrees down…

You’re ahead of me then. I’m still trying to get an “A” on the Take Off training flight!

I’ve not got on to landing the A320.

I tried the Bush Flight training flight on the seaplane with a gravel runway tonight. A bit hairy, but I got there in the end.

Also tried the F-18 Mirimar Challenge, but I’m pretty hopeless at that.

Good luck with landing the Airbus.

Peter.

Hi yperio, did you manage to land the Airbus OK? I’m onto that one now, but although I’ve managed to get the thing on the ground in one piece, I get no feedback from the instructor or score. Not a word is said.

oops… seems to help if you land on the right (as in the “R” right) runway.

@SelectDoughnut5 I managed to land a few times but have yet to do a decent landing. I’m struggling with keeping the 3 degrees descent.
The tutorial can be a bit buggy and there’s been a couple of times where it didn’t display properly for me.

You’ve probably seen this, but if not, does this help?