Flight Training VFR Navigation Part 1 take off

Please tag your post with #pc and/or #xbox.
#pc

Are you on Steam or Microsoft Store version?
Steam

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
In the VFR Navigation training session Part 1 “Departure” I have to take off. I followed the instruction and took off but the take off event is not recognoized. So I am not able to finish this lesson. A few seconds after take off the lesson is restarted.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Load the lession VFR Naviagtion “Departure” and perform a take off with the Cessna 152. See if the take off is recognized and if the lesson is continued

PC specs and/or peripheral set up of relevant:
INTEL i5 9400, 16GB, RTX 2080 Graphics card, CH Products Flightstick PRO, CH Products Padels and CH Products Throttle Quadrant

Build Version # when you first started experiencing this issue:
1.20.6.0

@GernotZet86 Welcome! I just tried to replicate your issue. Mine recorded the event fine.

I tried it too, and it worked fine. Make sure you climb at 75 kts, and aim for the waypoint markers in the sky. Turn over the airport when directed, and when you hit that marker, make sure you turn to a heading of 41 degrees, and you’ll see the golf course marker, so aim for that, and it will complete the training.
Regards

Hello,

It is really weird because it does not work for me. I take off at approx. 60 kts and climb at 75 kts as soon as possible but my take off is never recognized. So the take off commmand does not turn green and I do not get the order to climb at 75 kts.
Regards

Seeing the same behavior here. Game never registers leaving the ground, never switches to maintain 75 kts, or puts up the next waypoint for climbing. Only tested in VR. Tried many times with variations though. Always fades to black and starts over near the end of the runway.

I’ll take another look at it since SU7 has dropped since the first response. Hopefully we can find the issue quickly.
Regards

@GernotZet86 @aleiby
Ok folks. I tried it again now that SU7 is here. I thought it might change something for you, but it again worked fine for me.
Full throttle, lifted off around 60, let it climb a bit, and then pulled up the flaps, and continued the climb at 75 on the runway heading. Aimed for the first marker in the sky, got the command to start turning left, and continued climbing and lined up with the next marker, then finally saw the final marker, and continued climb toward it. Got the “OK” and a few seconds later, saw the marker for the golf course, and then it completed the mission and gave me a score.
If it’s still not working for you (and have not tried it in VR, so can’t speak to any issues there), we’ll look at it again and see if we can find something, or just report your issue. I’m not seeing anyone else with this issue, so there’s something we’re doing different.
Hope it’s worked out for you by now.
Regards

@GernotZet86 Hi, I’m wondering if you have any update on your issue? I’m facing the same since a few days. I’m new on this FS2020 goty version (steam/pc) coming from Xplane. Take off is never recognized despite a lot of attempts overspeeding, climbing, changing direction before the end of the runway but the lesson restarts and restarts… Thks.

I just gave this another go tonight, but this time in desktop mode rather than in VR. Same results. Take-off is never recognized, followed shortly thereafter by failure (auto reset to start).

Same here. I tried 5 times to take off. I tried taking off at different speeds and different areas of the runway. Mine doesn’t even wait 5 seconds before I am off the ground before it resets. A couple of the times it faded to black and reset the moment the wheels lifted off the ground.

I did not experience this with any of the other training missions or free flights.

New try with update 8 installed. No change!

I had the same issue and finally got it to work. I use the Logitech x52 hotas and it seems that 100% throttle is not 100%. There must be a check on that for your takeoff because once airborne, if I push the throttle with my mouse, it immediately checks the takeoff task.
I hope this will help you!

1 Like

I was having the same issue/problem as well! Your solution is spot on but I would like to add to it! To permanently fix this problem, while in MS Flight Sim, go into your controller options and make sure the device you are using is selected. Then go to the axis that you have bound for your throttle. Locate the “Extreme Deadzone” slider. I had to move mine from 0%(default) to -12% before the Sim would recognize 100% full throttle movement. Hope this helps!

1 Like

Amazing, I was giving a new try before to take into account both last comments… and it worked fine without any change except the last update received today (FS not started since about one week)

I get a different and weird problem. Once I have climbed to 6500 feet and heading at 41 degrees when I get close to the mountains I get the AI voice “you need to fly higher”. I tried it several times and eventually climbed up towards 7000 feet and got the message “maintain 6500 feet”. This is genuinely a no win situation, what do I do?
PC user.

Hi @SpringyCoder440
Are you still referencing VFR Nav part 1 lesson, or one of the later VFR lessons? I haven’t been able to duplicate this error on the Part 1 lesson. In Part 1, if I just keep flying on 041 degrees, it just says I’ve left the training area and do it again. It sounds like maybe you’re referencing either the dead reckoning, landmark, or solo nav lesson. If it’s one of those, I’ll try to recreate in the beta and see what happens.
Regards

Hi @Habu2u2,
Thanks for your efforts, sorry I should have been more specific but yes, it’s the third group of lessons, VFR navigation and part 1. I’m on 1.26.5.0 and I haven’t installed WU X yet.
There is also an anomally in lesson 2 part 7 (Take off and landing - First solo flight) in that the opening graphic in the lesson showing the circuit shows and initial height of 5,400ft yet when in the lesson, this height has become 5,700ft in the objectives window for the take-off leg. I found this very difficult to maintain the 75Kias AND reach 5,700ft. I did get an A after about 100 tries though but it’s still confusing for people as is this VFR Nav part !. Cheers.

1 Like

Sorry is this is reviving an old thread. Im trying to complete VFR Navigation: Departure. And im having issues with it.

I take off fine. And get a “well commanded speech” and then it tells me to climb to 6500feet at a speed of 75kts.

This in itself is almost inpossible on the game. In order to maintain a climb of 75kts, i can barely keep the plane at a 2-3 pitch. And i get a message telling me “you didnt climbe fast enough” if i forget about the speed. And just try to climb up to the right altidude in time to hit the second marker. I have to climb at near 15 degree pitch. Which aparently gives me an air speed of as low as 40kts. However i hit the 6500 feet. And make my turn to the 3rd marker. Flying level. And letting my speed increase to 75kts. When i hit the 3rd marker. I get no more notifications. Nothing at all. The only thing i get is “you need to maintain 6500 feet” if i drop my altitude. Ive tried everything. Even leaning out the mixture before takeoff. To give me more engine power.

Hi @Cerbrus2
A couple of things to double check. First, leaning is definitely required since you’re starting at ~6000’, so even though you’re leaning it, make sure you aggressively lean and check for any RPM gains. I’ve found MSFS requires aggressive leaning to peak power. Disregard if you’re already sure you’ve got that covered!
Second, make double sure you’ve pulled the flaps up after takeoff.
Lastly, something I’ve run across is that I sometimes don’t get actual full throttle unless I pull the throttle all the way forward, then all the way back, and then all the way forward again after I’m on the runway. It seems like sometimes it doesn’t read the throttle completely accurately until I’ve done this.
Short of those things, not sure what else it could be. I tried the mission again and it seemed to be working fine for me, but I know that doesn’t necessarily translate to working right for you. I know how frustrating it is when it’s not working right!
Regards

Thank You Aexukas. That fixed the issue. I also added flaps at takeoff.