FlightSimulator.exe - Application Error (0x80000003)


FlightSimulator.exe - Application Error

The exception Breakpoint

A breakpoint has been reached.

(0x80000003) occurred in the application at location 0x00007FF7348A9BF2.

Click on OK to terminate the program

OK

Here is an error report that occurred while I was flying within the sim. It ended up in a CTD.

Right after the above bug happened, I can’t start up flight simulator anymore.
I see this error trying to launch the sim.


Fatal error

Please make sure your hardware is supported by this application. Please refer to the ReadMe file. (D3D11Renderer_Z)


OK

The D3D11 error has now gone away after I installed the newest Nvidia Graphics drivers.

@nOksX, Has your issue been resolved?

Copi and paste in C: Windows System32

That’s for windows 7…

I can run the game fine now, however the Original Post was something I encountered mid flight.

Yeop I’m on Win 10 :slight_smile:

I’m pretty sure we’re all on Win10, since it’s a requirement for the sim! :wink:

Hi,

Just to confirm - updating your NVidia drivers resolved this particular error for you?

Updating the Nvidia drivers just meant i could get into the game again.
However that bug was a follow up error. The original bug was the CTD while I was in the sim.
That was posted 1st, the 2nd issue was resolved with a driver update.

I don’t know if I’ll run into the original issue again however.

1 Like

Have a look at your Reliability and Maintenance history. I was having a number of CTDs when I checked my history and I noticed that the GameManager which is Synapse 3 for razer products was having issues also. Uninstalled and the CTDs seemed to be a lot less. From what I read Synapse 3 has been causing a lot of issues in a lot of games. You might find something conflicting with MSFS in there.

Thanks for the recommendation. I do have Razer Synapse installed on my machine as I use a Razer keyboard.
I will try uninstalling it and see if it makes a diff. Too bad i’ll lose up on the keyboard lighting :stuck_out_tongue:

Before uninstalling I suppose just exiting them should be good ?

You are right here is a screenshot of my Razer synapse crashing ( I am mid flight hence the sim cockpit view on my second monitor) :smiley:

It doesn’t make sense though coz from the above screenshot it says flight sim crashed at 12:11 am and 1:57 am and Synapse crashed an hour later. So I’m not sure how you can connect the dots ?
It could be completely unrelated that the both keep crashing on their own for different reasons.

Hello there,

I had similar CTD errors right after installing for the first time the game, wouldn`t pass in the Fly stage when Loading. After some reading and updating every software and Windows, did also the BIOS and Chipset Updates for MainBoard, still no succes at that time. What I think it solved my issue was the fact that I had no Paging Files alocated in the system and did some tweeks setting up on the HDD the minimum Paging files - 16000MB and maximum 48000MB, and after this the Game loaded and I could fly normal and without any other errors.
So try it, maybe this is the solution, and give a feedback.
Good luck!

My Setup: AMD Ryzen 7 3700X 8-Core Processor 4.05 GHz
16 GB RAM4
Nvidia GeForce RTX2060Super with lates drivers.

What’s that? Where do you find that in Windows 10?

You can open Reliability Monitor in its own window by typing ** perfmon /rel ** and pressing ENTER in the Start Search box or at a command prompt.

Just tried it. Simply amazing! Thank you :slight_smile:

1 Like

I was able fix the x80000003 exception issue on my PC by setting manage virtual memory to automatic. Hopefully this change resolves it for you too. Here’s how:

  1. From the Search bar type Performance.

  2. Choose the Adjust appearance and performance of Windows. This will pop a Performance Options window.

  3. Click on the Advanced tab.

  4. Click on the Change… button in the Virtual memory section.

  5. Check the box Automatically manage paging file size for all drives

  6. Click OK

  7. Reboot your computer

Flight Simulator 2020 works great after this change!

Thanks fixed my issue also had been trying to solve this for some time now.

How did you figure this out ?