For all of you with bad FPS

Check out this video! :grin:

5 Likes

Good find! Although for me, Microsoft game mode actually lowered my FPS significantly over NYC. My best results have been RTSS set to Scanline sync x/2 61 and Vsync in game to 60. For whatever reasons, this has worked best for me. My monitor is 60hz 1080p, i7-9700k, GTX 1080ti, 32GB RAM.

3 Likes

Ya I found this video today also. Didnt help at all. Tried everything in the video, zero change in frames. Basically, game is cpu locked. Went from stock Ultra to stock Low-End, and only changed about 5 fps. Running i5-10400 and 1060super. GPU never really goes over 45% parked at Kennedy. CPU is maxed.

If you want a work around then turn off the AI on traffic guys. It take a some cpu juice and stolen some fps. It is responsible for these lag with time when you are playing. Your FPS will increase. You will surprise.

Thank you so much for this suggestion! Over the past few days I’ve been trying to figure out whether I should turn V-Sync on or Off, this gave me not an increase in FPS, but a much smoother experience and I think helped lower my CPU usage as well! I hope they fix the in game V-Sync

1 Like

One thing he didn’t add to his video in order to get full utilitazion of the GPU, If purchased from Microsoft Store:

Game Bar Page>Graphic Setting> Choose and app to set Preference (from drop down)
Select an App> Microsoft Flight Simulator (click add)
Options> High Performance

I think you can do the same thing with steam, you have to choose, add Destop App and find the steam version of Microsoft Flight Sim.

1 Like

Thanks for this find. Good information.

this is terribly inacccurate,

look here;

Bloom has zero impact on framerate. From my personal testing, I saw a difference of 1% to framerates, and that was a rough reading.

Depth of field is actually identical from off to ultra. It is only activated in hangar, pre flight, and drone camera.

Texture synthesis has measurably zero impact to framerates from the testing done at this time.

Setting priority to realtime causes stutter. Setting it to high can even cause stutter.

That memory overclock seems to be shockingly disgusting (too marginal) for a 2080ti.

He did not even test 2 CCX SMT off vs 1 CCX SMT on.


I full heartedly support watching his videos with adblock enabled if this is the type of effort he puts out.