Forever loading issue after Sim Update 6

The delay will be caused by one of your addons … best would be rename your community folder and create an empty Community one next to it. Test first empty and if that works just drag and drop one mod at a time to test until you find the culprit(s). Start with the FBW and the nixi etc as they are known to cause problems if not updated.

After updating, uninstalling or removing the culprit(s) delete the empty Community folder and rename the full folder back to Community.

Is there any official feedback from Asobo via thread that they are aware is this issue? Long loading times are getting on my nerves :worried:

1 Like

Yes. Asobo suggest testing without mods before blaming them

Which most of us here have tried to NO avail


Then it is likely there are remnants still within the sim or a marketplace bought mod is in need of an update (which may or may not even be ready).

Everyone here has tried removing all mods to no avail. We have found that airports with less buildings can load just fine. We have found that lower graphics settings can make it work. We have found that when it hangs, the network usage in resource monitor drops dramatically. We have found that disabling all star streaming in the sim can let it load.

All evidence points to this being a sim/server issue.


nothing more than a link to an article written months before SU6 about generic loading issues.

1 Like

I have not had a single infinite loading to reach the main menu, but I have constantly the infinite loading when loading the flight. Is sooo frustrating!. A few hours ago I was able to load 3 times in a row wihout a problem, but a few hours prior to that I couldnt load a flight after 4 attemps (both, big 3rd party airports and/or default/paid aircrafts and small default airports with and w/o paid aircrafts). It seems to be a surprisingly random issue for me, even though it happens 75% of the time.

Sure, that would help, however, personally, I have dozens of addons and taking into account I need about 20 to 30 minutes each time I want to test every single one (from starting the sim to finally see the cockpit) it is just way too much for me. It could take dozens of hours. Im not willing to do that honestly.

Lol @ twenty minutes but even then do you think it’s Asobo’s job to test your old FSX mods?

That’s why I said test first with no mods if that’s ok it should load in less than a minute or so (for me the bar only stops for about 10 seconds) . Then test each mod and if it hasn’t loaded in a minute then it’s suspect … failing that then keep the two folders and just bring over what you need for each flight. If it stalls then at least you’ll have narrowed it down.

You keep repeating this in the threads about this issue and you seem to be convinced this is issue is the user’s fault.

To begin with, I’ve read reports that users have wiped FS off their drive and after a clean install the problem returned, but since I can’t confirm this out of my own experience I treat this as “tentative”. Other people report having this problem in completely individual and random locations with stock Asobo and payware airports of all makers while the same stock airports and DLC works for other users who have the problem at some other place, with an airport of some other maker, completely random. I have only one affected airport but I can synthesize this location-shifting behavior to some extent. The diversity and randomness alone is a strong indicator that the DLC is not playing a causal role in this and if the DLC would be the cause of the problem, it would be pretty much all of the existing scenery DLC.

Secondly, this all worked fine before SU6. If a planned change in the core sim would break DLC from the Marketplace, Asobo would’ve likley informed their “partners” about that change so they all can take actions in time. But obviously Asobo did not do that, instead nobody seems to have a clue what happened and why it happened and the change (whatever that is) was unintentional, which is the very definition of “bug”.

Then the affected users (including yours truly) have identified an incredible number of temporary workarounds with a very confusing variety in target vectors - from halfways obvious deleting Content.XML, wiping scenery indexes, to temporarily turning off online functionality, removing liveries (!), temporarily degrading graphics settings (!)… and that all boils down to “if users shift little, unrelated things around in their installation, the problem shifts as well” and that would be typical telltale signs of a problem in the host software (for example a thread-safety/“race condition” issue). Others have suggested a problem with DRM, something timing-critical comes into mind but whatever that may be, it’s not users having messed up their sim with old FSX downloads as you suggest.

I personally own only 4 payware airports (3x Aerosoft and 1x Orbx), all released and purchased fairly recently and I learned many decades ago to be very careful, picky and restrictive about freeware content and “mods”, so my Community folder usually contains less than 5 items, the only permanent content would be GAIST and WeLoveVFR, which are not known to cause issues, I don’t use freeware aircraft or add-on liveries, nothing that goes into some other place than the Community folder and I certainly never installed any ported FSX stuff. I’m also logging any changes to my purpose-built FS system which is only used for that purpose, and the only change performed before this problem came up on my home airport (Aerosoft) was installing SU6. Since only this airport has acquired this behavior I had a great base to examine the problem at hand, this environment and my own findings about the problem confirm very much what has been reported and pretty much rule out what you suggest.

The problem is obviously depending on a whole number of factors, the overall amount of add-ons likely determines the likelihood and severity in which users experience the issue, but very unrelated things like graphics settings, whether or not you’re using multiplayer etc. have an influence. What all cases have in common though is that this is always depending on location, what location that is varies obviously from machine to machine and it’s quote possible that yours has the issue without you ever knowing it because you never fly in a region that triggers it and hence you never bought airports for that region.


I had one instance of this issue yesterday. I closed the sim after 5 - 10 minutes of loading. Restarted the sim and reloaded the same flight, now it loaded surprisingly fast, almost as the previous failed loading was cached

Anyway, is there an actual bug logging thread where I can vote for this issue?

A fitting of explanation to anyone that doesn’t understand the problem and blames users /3rd party mods He is convinced that we have issue in there own systems where as its MS and Asobo to blame for these type of issues. Asobo has to sort out which issue needs urgent attention so users have smooth flying experience. Us as a customer and players have requested it many times in past to fix these annoying issues.

These workaround won’t work for long time untill and unless they can investigate this issue themself and patch the game up to in next hotfix or update.

1 Like

Seems to take me more time loading into a flight than loading the sim itself

1 Like

Right there now is ongoing server problem with live weather and online services. There are investigating it so that might be the case

1 Like

Iv just had a quick flight in the Hawk and it seems fine to me as of 1 hour ago

1 Like

Live weather is not working at all check again and azure.and even photogrammetry bing maps seems work very little live traffic as well in big airports

Azure and live weather are working fine for me in the Euro west coast server …Might just be a server related issue as of now ??

Looks like many more are experiencing the same issue
Glad someone made a bug report​:+1::+1:

I highly request everyone to vote on this bug

Thank you

This issue is on avsim fourm too a widespread bug

1 Like

no more problem since Tuesday for me
(a32nx experimental, fsdt kord, lvfr kmia, feelthere krdu, pushback toolbar installed)