Forever loading issue after Sim Update 6

I’m having this same issue. I’ve tried pretty much everything. No luck yet. This only started happening to me post SU6. Absolutely bizarre.


UPDATE: Deleting the scenery index(s) AND setting LOD to lowest seems to do the trick. I’ll keep testing. It’s kind of a pain, but it is a doable workaround until Asobo and address this later.

Thanks, but what do you mean by delete the scenery indexes?

OK so i have done a bit of testing and found this:

First I tried loading into KLAX. This run actually worked and it loaded in as normal (with 100 LOD) While observing resource monitor the network total by MSFS was normal (showing 1,200,000 B/s)

Then I tried to load into KLGA, same settings and all, and this time hung at 100%. watching resource monitor I roughly the same network usage by MSFS, but at about 75% on the loading bar, it quickly dropped and showed no more than 1000 B/s.

Alt+F4, wait for FlightSimulator.exe network usage to stop, reload game.

load right back into KLGA, same gate, same settings. watching network usage, it looks good and it loads just fine.

This could be a fluke, but I don’t have the time nor effort to test it 100 times, and it has also seemed to work for you. However this does give us and Asobo a solid basis for identifying the issue. My guess is that something is broken with the server or the game reaching out to the server. the LOD solution also supports this as a lower LOD may require less network usage and therefore it doesn’t get stuck from this issue.

Listing solutions for anyone coming through here:
Setting LOD and other settings to lowest, loading in, then turning them back up.

As shown above: attempt to load in, alt-f4 when it hangs, watch until FlightSimulator.exe disappears from resource monitor, reload game.

delete content.xml (hasn’t worked often for me)
delete scenery index .dat files / delete rolling cache (also hasn’t worked well for me)


All - as has been mentioned here and by me, servers are being affected, mostly random. I cannot prove it but MSFS may be under some sort of attack from neferious folks, farfetched, maybe. To many players are having this issue randomly to just out of hand discount. PLUS-Servers are/have been wonky for the last week, up down all around. AND, suspect SU6 fixed something, which has allowed this to come to the fore. I am not changing my Graphics settings, as rarly do I start flight from major area. Closets to big one is KATL or KMGE as orgin. I then fly to KMEM-Nashville, Chattanogga, Athens, GA or the like. Has anyone documented a “plane type” which is most affected, not saying that is it, just curious. I mostly fly F-14 but if Destroyer121 gets his C-17 up to snuff, will fly that. The Boeing 747 would be third choice, but again, I need to practise in it way more than current. I have NOT experienced this issue. Game last I timed it, 3.47 minutes/seconds from mouse click to Main Window. Loading a flight seems to take minute or less. I will report back here if I experience this issue, so far the only anomely is stuffering which I did not have before.

I have experienced this issue several times the past couple days. I was trying to change the time of day in the world map while staying on live weather. I restarted the sim and kept it live weather live time and it loaded fine. Maybe random maybe it was causing an issue. Who knows.

I have no mods loaded and have removed the Content.XML which worked initially but I can’t get a flight fully loaded after that. I’ve tried different airports, as well.

In the past, I’ve suffered through some temporary CTDs, some graphical snafus, etc., but this time it has proven to be a show stopper, for me. I guess I now need to try the initial lower graphics settings/revert back to higher once the flight loads work-around…

Hopefully this newly introduced issue can be fixed sooner rather than later.

1 Like

Don´t delete anything, will not work.

At now the easiest solution is to load a small airport and then move the aircraft with slew mode using de “Dev” option listed before or “fstramp”.

The other way is to set the lowest settings “Graphics” and once you are in the game set them back to where you want them ( this is a ■■■■■■ ritual as many options won’t load but only after you reset the game).

We shouldn´t be expending our time on this, but in playing.

Asobo should really start paying attention to our fatigue as at some point it will become a trigger for whatever we prefer to do. It´s being one year! and sometimes I don´t feel that I have a game as I don´t know at what moment will have a CTD or a painful update.

Instead of “placing buildings” and offering “drone planes”, they should be putting all the attention of the team, on things like this not to happen.

Instead of thinking about how to manage the weather, they should give us back the weather stations and smooth transitions between them.

Instead of…, they should play open doors in all the original models so we can play with what is ok now.

I am only saying that we need what we were used to having at the interphase, and once everything its ok, then we can start innovating with intensive beta testing teams.

ATC is a mess as well as Traffic management when we can´t even assign a parking spot to a certain airline at de SDK.

It is becoming a Frankenstein… Happy Halloween. :jack_o_lantern:


i agree, i don’t like deleting anything, but people said it worked for them so i listed it.

as for the gfx workaround, setting the LOD very low will do the trick, so no need to change all the ones that require sim restarts.

but the best workaround is no workaround. it should just work like it used to dammit!

I too am having this. Loaded a flight at a stock KSAV and it took 25 mins to load. Did have the Bell 47G loaded (that’s what I was flying), but that was it.

Is there a bug thread on this we can vote on?

BTW, the solution is not a solution and should never have been chosen as the solution because it makes the thread look as if the fix was found and the forum software then discourages people from posting in the thread.

The post was marked as the solution because it solved the issue for the OP. It’s not meant to say that the solution will help other posters in the thread. Confusing, I know but that’s how this forum rolls. :wink:

For giggles I left the sim to “load” for 4 hours while I was out running errands. Came back and it was still at 100% -_-

Hi i have removed the solution tick from thread as it wide-spread issue as the workaround is just temporary fix . The workaround did seem work but as far i can see lot of other have issue so its still unsolved untill now.

Sorry for causing confusion as i was myself trying to find the solution :pray:


Its just temporary fix i have removed the solution tick so other can post as well

4 hrs lol my god :scream::scream:

1 Like

So I think I MIGHT’VE figured out what might be at play: As someone else above mentioned, this seems to be a server/connection issue. When a flight loads in correctly, the network usage by the sim will spike a lot and will rarely drop below 1Mbit/s. When the flight loads forever, the network usage drops to 0.1Mbit/s or MAYBE 0.2. This would also explain why it seems to happen at random, and nothing else fixes it. Even disabling online services might not necessarily work without a clean shutdown and system reboot. Changing the LOD settings also might not make a difference because even with LOD 10 the sim is still trying to download a decent amount of data, at least in complex areas like NYC/LA. Testing will continue…


It is farfetched. What people should understand is that a percentage of servers break or go bad all the time especially when major sim updates are involved … and in some locations they have resorted to using dry ice just to keep them operable.

Then either need more servers, or much better cooling for them. Or the demand has far outstripped the infrastructure as first designed and laid out. Nevertheless, when something worked yesterday and does not work today, then my root guess is a server issue, UNLESS, some update was pushed out. Usually the updates are announced well ahead of time so we all prepare.


I have same issue since SU6. Loading forever and ever…

1 Like

I think this is something we’re going to have to wait out for a fix :weary: Hopefully sooner rather than later since this has made the sim 100% unplayable for some of us. I haven’t been able to load into a single flight since updating to SU6. I’ve tried everything I possibly can including reinstalls but to no avail. Fingers crossed this issue is acknowledged in the coming days and a fix is released shortly after…