FPS drops...NOT FLYABLE!

Hi…i would like to share a recent problem here and maybe some of you have the same issues.

I use a i9-10900k with 64GB RAM and a RTX 3090. The PC is only for MSFS and nothing else is running on it.
When i use Medium settings, turn off AI traffic and set the weather to preset to “Sky clear”, then i get around 30 FPS when i place the aircraft on the runway.
I can see on the FPS Counter “Limited my Main Thread”

Around 10 minutes later, i dont move the plane or change anything, my FPS drops to around15?!?!?!?!?
flying with weather is not possible: FPS 1-5!!!

What is going on here???

I have tried several tweakes from Youtube and the INternet but actualy there is not a real improvment

Any ideas? Someone got the same issues???

Thx a lot and stay healthy

Klaus

1 Like

Only way to stop the dramatic FPS drop is to turn the whole ONLINE FUNCTIONALITY: OFF

I remember Asobo / Microsoft did a server boot last week, could this be the reason…

I have the same problem. 60fps and suddenly drops to 15fps. It since world update 3. Live traffic and multiplayer off.

2 Likes

Yes getting the drops as well since the last update.

Same for me

Check your temps
If your case cooking is not good then maybe the Cpu &/or Gpu is throttling down

With that hardware you should be getting FPS of 50-60 in 4K High settings in more remote areas and 35-45 in cities. If your temps are ok (less than say 85c) then it’s not likely thermal throttle and something is not right in settings somewhere. Have you ever had better performance before a recent MSFS update or has it always been this bad? Turn off multiplayer, turn off live weather, turn off live traffic. Check NVidia driver for an update. Some folks use an older driver (457.3 I think?), but I have a nearly identical setup to you and am running the latest NVidia driver no problem. You could try deleting the rolling cache and let it rebuild. Turn off game mode in windows, make sure the Xbox settings to record your video are off (they are in the same place as the game mode settings). Check the NVidia control panel settings and maybe set them back to default and then toggle to those recommended on the forum here. Post back if you need help and I can link some other posts that show that stuff. And after changing settings in windows, NVidia and MSFS, I tend to shut down and reboot the machine as well. A last ditch effort could be to uninstall and re-download the entire game but that’s such a pain that maybe hold off on that .

Thank you very much Sir for your reply!

I actually have done your recommended settings already. Have the latest drive and the watercooling is doing a great job on my CPU.
Even the GPU is not getting that hot, the fan don’t even go on full speed.

Today I tried different settings and mad a flight with no weather and no AI traffic.

I started in Vienna with 70FPs and around one hour flight time I had 10 to 13 FPS

The FPS is steady going down without any recovery.

Usually when the scenery is getting less intense you can see a recovery and FPS.
There is no improvement…

If I check I can see that one CPU core is always at 100% while the other ones have lots of space for a workload.

I guess it is a software issue… I don’t know how it was before world update 3.

Maybe MSFS is not yet much adjusted to mulit core usage.

Hope that will change…

Anyways… Thank you all guys for the response…

Stay safe… Stay healthy…

Klaus

LOWW

1 Like

Yes, the general consensus is that 457.30 is the best for FS2020 and FS2020 VR. It will likely remain that way until Nvidia comes out with drivers that are specifically designed for FS2020 and/or FS2020 VR tunings in mind, though sometimes they don’t necessarily label them as such.

Thank you Sir… I will download this particular driver and give it a test.

Temperatures - give them a check
Nvidia Drivers - did you update recently
Nvidia Geforce Experience - make sure its Optimization is OFF
Render Scaling, in MSFS’ Graphics Settings - somehow mine got turned to 200 - slowed my PC WAY down (R9 3900X, 2080Ti, 64GB RAM, Nvme drives only)
Also had issues with the FPS settings in Graphics - temp turned them down from 60FPS and forgot to turn them back up :slight_smile:

Maybe some of that might help - I hope so and wish you luck.

Well I was having serious frame drops, with the “main thread limit” after a few minutes of play. Anywhere from 6-15 minutes in. I tried all the stuff in this thread to no avail. Then I uninstalled the MSI dragon center (my laptop is an MSI gaming laptop) and the problem seems to have gone away so far (a few flights of over 30 minutes now, with good framerate throughout)

HAD THE SAME SAME PROBLEM TOO, Any solutions found please?