FPS is pinned at 10fps when a window is popped out (eg the PFD, GPS Screens etc) until pop out window is made full screen

When popping out a window (eg a GPS screen - which I do for my RealSimGear 430) the frame rate is pinned at 10fps (for the whole sim not just the popped out window).
A workaround for this bug is to make the popout screen fullscreen with Alt+Enter (then you can make it not fullscreen again and it will still be ok) which for some reason makes the sim perform properly again

Even after doing that the frame rate is significantly lower (for me about 10fps less than without the popped out window) though which I guess is also a related bug (since popping out a window surely shouldn’t impact performance so much?)

See linked video where my FPS is in the top chart on the left in MSI afterburner and you can see it change when I pop out the window and when I change to full screen: https://youtu.be/PeiOse8ygRE

Zendesk #115111

Users that experience a performance decrease, but are not locked to 10fps can take a look here.

@NickD2576 is game mode enabled in Windows? Does turning it on/off before starting MSFS make a difference with the issue?

I have just tested Game Mode. It was not enabled so I have turned it on and tried out MSFS but I still get the 10fps bug

Was worth a shot :pensive:

You likely have Vsync / frame rate limiter turned on either in the sim or in your video card’s control panel. That completely messes up your frame rate when you pop out windows and tanks you down to 10 fps. It does it to me as well. The way the sim handles frame rates when dealing with multiple viewports is very, very bad.

Make sure Vsyn in sim is disabled and that you’re not limiting frame rate in your GPU’s app, and you’ll see those frame rates jump back up.

After SU5, popping out a window of any kind is an instant 15 fps penalty. I can normally run the CJ4 at 45-50 fps without pop-outs now. In this pic, I’ve got the PFD, MFD and MCDU windows popped out onto my 2 touch screens and embedded in my Air Manager panels, as well as my ATC window undocked an onto my right side monitor. You can clearly see the 30 fps counter on the screen.

opening a window in MSFS reduced my FPS automatically by 50% and locked it.
running 60FPS locked and opening i get 30 FPS locked

Turn off vsync and that problem goes away. You’ll still lose about 15 fps for undocking that first instrument, but that’s it.

that should be off… or has SU5 reset again some settings… will test at the weekend

ALso make sure that your monitor maximum frame rate isn’t capped in your nVidia / AMD control panel (whichever you have). It has the same effect as having Vsync on in the sim.

both set to default 60Hz, thats the reason I locked ingame to 60 as well

Unlock it in game. That’s the issue.

It SHOULDN’T behave this way. It’s clearly a bug. But this is the workaround. You can see in my pic above. I get 45-50 fps in that plane without anything undocked. The second I undock the first instrument, I drop to 30-35 fps and that’s my only loss. In that pic, I have PFD, MFD, MCDU and ATC windows popped out and moved to other screens. You can clearly see the 30 fps on the frame counter.

problem at the moment with SU5 is that unlimiting the FPS will kill some GPUs in the loading… (actual might have happend to mine…).

The sim has been pegging GPUs in the menus and laoding screens since launch. It has nothing to do with SU5 at all. It’s been running my 2080 full tilt at 300+ fps and 85°C in menus since the first time I fired up the sim on launch day last August.

might be my GPU, had no problems before SU5 with temps up to 85, but two days ago it got busted during the loading screen. 3090 are not that solid working at the moment… (killed by first just two months ago with a faulty VRAM modul)

Instead of using vsync in game, lock it at 144 in the nVidia control panel. This may be above your actual refresh rate of the monitor, but should keep GPU usage more reasonable in menus while giving you more headroom in game with windows undocked.

Asobo really need to limit frame rates in the menus though.

So I have tied a couple of things… I turned off GSync and made sure vsync was disabled everywhere (in game and nvidia control panel), and I also disconnected my other monitors as I thought maybe this could be a multi monitor issue, but nothing has chaged.

Here are some screenshots showing the in game FPS counter before and after closing the popout window. You can see it is clearly pinned at 10fps with the popout there. I find it interesting that the frame time when the popout is there is ~96ms but adding up the times below (MainThread, RenderThread etc) it is still only about 25ms. Where could this extra ~70ms be coming from??

I also find it interesting that the FPS counter thing says “Tearing forbidden”. Is that normal? That seems like something is still forcing vsync which is maybe the problem?


i did the same : other monitors dysconnected, with/without GSync, a lot of NVidia param tested… allways the same résult, 15/20 fps dropped when undocking panel (asobo’s aircrafts).
Tired by bugs…