Frame limiting issue

Just hotixed su5. Not sure whether this happed before or not as only after the hotfix did I try limiting fps for CTD reasons. Anyway, I have Nvidia CP limiting fps to 30 and vsync also set at 30 and Nvidia overlay is showing 77 avg fps at altitude. I9 9900k 2080ti 32g 3200mhz.

P.s. no ctds but I have to set priority to low and affinity to all but core 0 and 1. Running 100 % render scale at 1080p. Even 200% still gets 69fps.

Bottom line, why is it not limited?

I use a frame limiter (through NVIDIA settings), and that seems to be working fine. I use the dev mode FPS counter, though, not the NVIDIA overlay. Have you tried other FPS counters?

No I havent. Never figured a reason the actual gpu software can’t detect that accurately. I just flew from Nassau to KATL and it only seemed that the fps started to limit and stay at an easy 30fps once I got below 10k ft. Starting to wonder how much is actually related to xbox settings. Still no CTD since I’ve gone through every walk-around on this site. You name it, its done. Only CTDs were 1. Just after hot fix for SU5 was installed. 2. Forgetting to run as administrator and forgetting to stop “nahimic” service.

I’m only consistently successful avoiding CTDs as long as the Microsoft Store App is open in the background. That dang thang is the only thing that seems to keep my sim running.

1 Like

i use the ingame V sync ON and Frame limit on 60 , on my 3 screener with devmode FPS counter it gives about 45 FPS but with a lot of red flashes limited by whatever.
So what does this button do , i set the frame limiter to 30 FPS , game still goes to 45 FPS but now with No red flashy things… now testing with teh Nvidia Vsync and frame limiter for a steady 40 FPS and see what that does.