Frame Rates stay on

I just updated to 19.5.5 When I turned on frame rates I was not able to turn it off. I would turn show frame rates off, they went off. But when I turned on dev mode, they came back. What I had to do is turn frame rates off, save and exit because the menu was still there. When I came back into the game, I just turned off the menu and that fixed it. Has anyone else seen that, if not I will let it go

Hi,
yes it is the same for me. What I do is : I turn off the frames, then I set developer mode to off.
Save and exit.
Not a big issue.

Tried it in an older version. You need to turn off the developer mode and restart the game.