Freelook Mouse Control is STILL Gone

Not much to add, except I don’t see why so many of these issues have been marked “closed”. I have tried for ~1.5h now using all forum posts available and cannot get the freelook mouse control back to regular functionality.

1 Like

Topics not in the bug reports or wishlist section are automatically closed after 30 days of the last reply.

What is wrong with your freelook mouse control? What is gone about it?

It locks out controls since Su5. I think you just have to understand that this is the intended behaviour now. If they haven’t managed to resolve it after 5 sim updates it’s fair to say it’s never going to be fixed.

Get into the habit of flicking your mouse around and repositioning and letting go of the button.

I suspect this change was brought about to allow Xbox controllers to pan using the sticks without affecting the flight controls. I’d love for the behaviour to be disabled if your aren’t using a Xbox controller for flight control or better yet give us a toggle in the options, however maybe the way the underlying input system is coded makes this quite difficult.

Mahbe create a wishlist topic about adding a toggle for this in the options.

1 Like

What exactly do you want a toggle option for? There are already two toggle freelook options, so I suspect you must mean something different.

Just try it out first, right click hold to freelook locks out your joystick control inputs. This means if you look around using the hold to freelook option while taxing you go careening off into the bushes.

The toggle freelook options still works as intended and your flight controls all work, but it not as intuitive since you need to toggle it off to use your cursor.

Like I said maybe it’s intended behaviour but it worked differently prior to Su5. Many of us liked being able to hold and look around while flying the plane.

1 Like

This issue has been around since SU5. If you look at the last development blog post, you can see its labelled under the “Lifetime Bugs” category. Asobo is defnitely aware of the issue, but not sure there’s any intention on fixing it soon. It’s still labelled as “Under Investigation.”

If anyone finds a bug topic that as been “closed” by the “system”, please send a DM to @moderators to have it reopened. :+1:


I use Freelook all the time, and my rudder pedals and all controls still work.

I can’t use the Bravo yoke when at the same time using Freelook with the mouse. I stopped using FS when this bug appeared and am still waiting for a solution.

1 Like

I use CH Products Rudder Pedals and Multi-Engine Throttle with a Logitech Extreme 3D Pro Joystick (The CH Products Yoke works, too, but, I don’t use it).

Are you using hold freelook or toggle freelook? Toggle has always worked fine, hold has been bugged since su5

ah, ok… Toggle

The right click still does block the controls, but only in the cockpit!

The right click and pan functionality works perfectly outside the aircraft.

I just think that this feature is simply way down their list of things to fix, which is quite disappointing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.