Freelook with mouse causes controls to freeze after SU5

Come on Asobo, STILL HASNT BEEN FIXED

2 Likes

Along with a dozen other small things, but we’ll get there in the end, I have no doubt.

1 Like

Almost 12 months! I know it’s not the most game breaking bugs ever but I’d still like to be able to steer the plane whilst quickly performing some cockpit housekeeping.

3 Likes

One more sim update and still this is not fixed, very disappointing, specially for something that worked fine on launch and got broken on SU5

7 Likes

Agreed. They don’t seem to understand how this looks on their QC team. How can this not have been noticed when it took me literally 5 minutes into SU5 to see my controls would freeze in the input they were in before I moved the camera.

1 Like

Perhaps, but I’m starting to lose faith. Instead of spending 60 minutes to simply fix this once and for all, they’ve opted to work on fictional aircraft for marketing gimmicks instead.

To all the people saying MSFS is a serious sim: are you sure? Because Asobo’s actions don’t seem to agree.

Different teams. In much the same way as the security guard at Asobo HQ isn’t preparing lunch in the canteen.

Though I take your point. I look to future movie releases wondering if there are any big aviation related ones coming…

1 Like

So frustrating especially with addons like the fenix where you have to quickly glance across and the controls lock up, how has this not been fixed, its been A YEAR!

1 Like

this topic should get pushed into the next Q&A, they have to at least explain why this is still not fixed and ‘‘under investigation’’ for a year now.

1 Like

Tried doing that. They said it was not part of the beta, so it wouldn’t be allowed into the QA.

1 Like

If that is what happened, it is possibly not THIS bug, but another one from a long time ago.

The cause was losing focus on the main screnn, and it would stick to the VFR map, or the ATC chat window. The solution was to click off the window back on to the main view by using right click. That made everything work again.

I am a little confused as to why people are saying this causes them to be unable to look around the cockpit quickly. I have no trouble using right click to look around, let go, then carry on as normal - click the things I need to or use the controls - without ANY issues.

On the ground, when taxiing, I use the middle click to look around, then right click to cancel it.

Using EITHER of these is NOT a problem after one minutes practice.
Maybe someone can explain to me why people are saying they cannot quickly look around in the Fenix, when the A32NX has no issues like this, nor ANY other aircraft I have flown.

All aircraft have this problem, it’s not a problem with an aircraft, it’s the UI. I think the reason it’s such a problem is that it worked fine until SU5, which was over a year ago. The devs have addressed this in their update videos (albeit somewhat tangentially), and have stated things about fixing mouse interactions since the SU5 update, but have not fixed this seemingly minor issue.

It may be fine for you to middle click to look around, and we’ve all had to do that now, but IMO, it is faster, simpler, and more intuitive to use the right-click method. We can’t use that method now because it breaks all control input while you have the right click down (For what reason, nobody can fathom)

1 Like

It’s an workaround, not the solution. Saying it’s not a problem in a thread with almost 400 votes is kind of ignorant.

The middle mouse click is an toggle option, which means an constant unnecessary extra click for something so fundamental.

Holding the right mouse button was definitely a much more comfortable and better option, but it got broken a year ago while they made the sim X-Box compatible… make of it what you will.

1 Like

Yes, we know. That’s what this thread is for. Just carry on using them until it gets fixed … that’s why I voted for this when it first got posted, and commented back in Sep 21.

If I don’t find it a problem to use the workarounds, then neither should anyone else at this stage.
Yes, it would be great to get things back to where they were, but the difference is so negligible …

NOWHERE did I say that this issue is not a problem.
I said that it’s not a problem using the workarounds like we have been for over a year.
Calling me ignorant is going too far - just don’t attack people, and certainly not by misquoting them.

And? We have reported the problem, and are waiting for a solution.

1 Like