Freelook with mouse SERIOUSLY broken since Update

The issue is solved now since yesterday’s update
Just in case nobody noticed hahaha

PERFECT PROBLEM FIXED BY ASOBO

ITS PERFECT IN COCKPIT VIEW AS IT WAS BEFORE.

And by the way I got a 35 to 40% framerate increase for free since yesterday. Basically a CPU and GPU UPGRADE FOR FREE

RTX 3080
AMD 5600X

THANK YOU ASOBO

This topic could be closed now.

if you try and free look with right mouse and use rudder at the same time it will jam your rudder lol

1 Like

you’re playing XPlane right?

one thing they did was add this option, by which you can reduce it… only! THIS is NOT fixed!

2 Likes

Hello everyone,

My free look with mouse stopped working after the latest upgrade (1.18.14.0) … free look is working fine with the keyboard (shift + 2,4,8,6) or an XBOX ONE controller. I’m using a THRUSTMASTER T.1600 and THRUSTMASTER TWCS Controller (not sure if it matters) … no change in my configuration since the beginning … the mouse works fine … does anybody else has this problem starting 1.18.14.0 ?

Thank you !

Mine is still working the same as before. I have the T.16000.

If your mouse mappings are still okay, I would unplug the mouse
and uninstall the drivers and the Controls Options for the mouse.

Reinstall the mouse and see if it works now.

1 Like

This is mouse sensitivity and not directly Freelook related, but I’d rather avoid cluttering our forum with a new topic for such a small thing:

Dear community, does anyone have the issue of the “Reactivity” setting (I think it’s called like that) in the controller sensitivity settings not doing anything anymore since the v1.18.13.0 ?
Be it the yoke, joystick, throttle quadrant leavers…set to either 1 or 50 or 100 the Reactivity setting just doesn’t work anymore…for me.

I have a few ideas on how to go about it on my PC, yet better to ask you first in case it’s a widespread thing.

Thank you everyone !

1 Like

Thanks for the tip ! … I tried with a different mouse also … that didn’t work either. What DID work though was to start MSFS with the mouse turned off … than I turned my mouse on while I was in the Options->Controls menu … apparently this WORKED … everything is fine now. Thanks man ! Much appreciated for you ideas ! … :love_you_gesture:

1 Like

Its not solved. FYI.

My freelook with my mouse its not working fine inside the cockpit.

This topic can’t be closed.

1 Like

fare kokpit içersin de dolaşmıyor sabit. bu sorunun çözümü nedir? son yapılan güncelleme sonucu fare iptal oldu

interesting, i will try it now

ıt hasnothing to do with this option after the last upgrade the mouse is not of use. ı think the problem should be fixed with a new update. ı can’t use the app right now.

Ok … let me get back on this one … after the latest update (1.18.15.0) I realized free look doesn’t work anymore with the mouse (again). The trick mentioned by me in the previous post didn’t work either.

BUT … after I unplugged my TWCS Throttle controller (Thrustmaster) … free look with mouse worked again … plugging back the TWCS Throttle → no free look with mouse.

The TWCS Throttle also has some default mapping for free look … I used free look with the TWCS Throttle controller (with muse plugged off)… then I plugged in my mouse back … it looks like now is working … I don’t know exactly what is happening but apparently there are some issues with multiple controllers plugged in

In my case it was clearly that the TWCS Throttle controller was causing this … give it a try … try to unplug your controller one by one and see if any of those are causing this.

I used this last night, and it seemed to work as I remembered.

Hold right mouse to move view around, release to stop. Or press the middle mouse button to lock freelook. I don’t have a TWCS Throttle, but a Virtual Fly TQ6+.

I also has the negative mouse acceleration issue, where small mouse movements can lead to no movement on screen at all, which makes moving the view around more jumpy than it should be.

They are treating the mouse as if it is a console controller joystick, with relative input, and not absolute input.

1 Like

One thing I’ve noticed since the update is that when using the right mouse button to look around, I lose joystick functionality if I’m holding the mouse button down. I’ve had to consciously remember to release the button if I need to make an adjustment to my bank angle or attack angle. I don’t remember having to do that prior to SU5. Not sure if this is a bug or if I have a setting wrong somewhere.

2 Likes

I don’t have a joystick, but when I get home I will double check I can use my yoke as expect while holding down right mouse, as well as clicking the middle mouse button.

1 Like

Known bug.
Try “mouse wheel button” (mid-click)

https://forums.flightsimulator.com/t/cannot-steer-aircraft-when-using-mouselook-right-click/426665/2

1 Like

Thank you, I will try this out later.

1 Like

thank you for bringing it up again, still the same issue…

@JrPainkiller606 @TenPatrol your issue is a different one and is discussed in other threads

I re-tested this, and I cannot use any of the primary flight controls while the right mouse is held. If I hold the mouse, then move the yoke, when I let go of the mouse button the yoke graphic jumps to the location my physical yoke is at.

The middle mouse button however does work, and I can move the controls while looking around.

1 Like

Hello dear flightsimmer,

about 6month ago or even end of 2020, I don’t remember for sure ,I suddenly lost the free camera usually commended by maintening the right mouse button. This feature disapeared from one day to the next ,and I could not move the free view camera anymore bur had only access to the Shift +2,4,6,8 to mov the view. and today for the 100th time or more I had a look in the command setting for mouse and suddenly noticed a sensitivity button at top left of the windows,had a look there and saw this sensitivity that I thought totally unneceesary for such device was set to 10%? just moved the cursor to 50%, went back in the simulation and thank God (or whoever you prefer to thanks), the free camera view is back moving the external view and cockpit view smoothly and precisely.
Hoping this information will help those who were looking to recover from similar problem…
Have a good day (or a good evening).

1 Like