Freeze after 1 hour in VR

I have reported this several times and it keeps getting removed without explanation. MSFS 2020 Freezes after about 1 hour (a few minutes more) of flight in VR. It will briefly stutter, then completely freeze. I have tried using Intelligent Standby List Cleaner to purge unused memory, and other things, but the problem persists. This problem has persisted from release August 2020 to present (June 2021). I am using a NVIDIA 1080 TI video card and have a rather high end I-7 with 32 GB of RAM. The problem acts like some kind of memory leak in the sim. I would hope that someone at ZenDesk or the developers would answer my issue instead of just close the ticket after saying this is similar to another one. I went through other issues in the forum — this one is different. Maybe I’m the only one who flies for a couple hours at a time in VR?

I was just about to report exactly the same thing concerning unexpected CTD. I could not repeat it at the same location in the World Map (Approach to FAEL) but it was almost exactly an hour into the VR flight. Just tried it again in a totally different area ( EGLK) and after 1 hour 5 mins it crashed again.
Oculus #rift S - App version 30.0.0.36.502 (30.0.0.36.502)
AMD Radeon RX5700 XT Driver 21.5.2
MSFS 1.16.2.0