Freeze freeze freeze

My simulator aircraft is freezing and staying stuck in the sky…

Happened a few times now. Aircraft freezes, you can still look around and move views, no buttoms work and outside contrails are frozen. It’s like active pause but its not. No active pauses active, quick keys are not pressed.

Really getting frustrating now.

All started 5 days ago! Is Asobo testing an alpha release on the servers or somthing.

1 Like

It has not happened to me, so the problem is with you, I’d guess.

Saying that, what you describe is Active Pause, so summat has triggered it.

1 Like

I’m going to have to drain the community folder I suspect

Check for a key binding bound to active pause possibly?

Topic moved to #community:general-discussion-feedback for advice.

The Bugs and Issues category is for base content. No 3rd Party addons. If you continue to have issues after removing all 3rd Party, you may then post in #bugs-and-issues

I was experiencing freezing at various places within the simulator, but I may have discovered a solution. In my case, I noticed that when MSFS freezes, one of my hard drives was running 100% of the time but with relatively little read or write activity.

So I searched on Google for the cause of 100 percent hard drive time and found several pages that suggested that a Microsoft service called “SuperFetch” was the culprit. This program is supposed to optimize hard drive access but can cause hard drives to become unavailable for short periods, causing the freezes some were seeing.

Executing the following command within the CMD prompt using admin mode stops SuperFetch until the next reboot of the system.

net stop sysmain

After running this command, the active disk time dropped down to normal levels, and I think that will stop some of the freezing within MSFS.

It is possible to disable SuperFetch completely, but that might not be the best thing to do. It’s also possible to tune SuperFetch, which might help the situation, but I haven’t tested that. If you want to try, check out this article:

https://www.itexperience.net/3-fixes-for-high-disk-usage-caused-by-sysmain/

Additional Note:

Unfortunately, turning the SuperFetch service off did not completely stop the strange disk activity. It does help with some of the freezing, but certain actions in MSFS seem to kick off 100% disk access and that causes another freeze. There are other measures that may fix that, so I’ll be trying them to see if those measures will help. I’ll post again if I have any success.

2 Likes

Started happening to me as well in the last week. I run zero add-ons on my PC and drivers are up to date. No CTD, just freezes solid.

1 Like

One more service in addition to SuperFetch that seems to be hogging the drive access is the “Search” service. To temporarily disable it use the following command at the command prompt running under admin mode:

net stop "Windows search"

Like the SuperFetch service, “Windows Search” will restart at the next boot unless you disable it completely.

I just did a flight around New York without a single freeze. That’s a first for me.

To recap these two commands on the command line will temporarily stop services that can cause freezing.

net stop sysmain
net stop "Windows search"

Use task manager during a freeze and check the Performance tab. If any of your disks show 100% usage during the freezes you are experiencing, try these commands out.

1 Like

Here’s another article about high disk access describing several approaches to the problem, including what I’ve mentioned above. Item 7 about the AHCI drivers on Windows 10 sounds especially pertinent.

I’ve had this since the 1.21.13.0 update, I haven’t managed one flight without it yet. I’m going to try the tips from @UnitedSFReader to see if that helps :crossed_fingers:

I have stutters periodically, but my MSFS is on an SSD Drive, so latency should not be problem. After flying for few minutes or less, they go away. I regularly defrag drive so don’t think it’s that. I laid it at the server usage door, but will read the above link.

I tried windows 11, some good some bad, lost what I consider great functionality getting to task manager by clicking in free space on taskbar, and getting back to desktop. In 11, printer driver had to be reinstalled every update, and volume on my ear buds was low, but then remember I needed to install a driver for them, which I forgot. But just used to 10, so went back to it by OEM recovery USD stick. File path in 11 is longer since it’s a straight 64 bit OS. Think I am going to wait 6 months and give it a whirl then.

FYI the thing that seemed to help me the most was that item 7 in this post: