Freeze on "Xbox Game Studios"-splash screen

Since yesterday, I cannot start MSFS anymore. When I start, it stops at the splash screen. Sometimes it shows a complete black screen only, sometimes, I can see the content of the splash screen (XBOX GAME STUDIOS". Nothing further happens anymore.

Since update from Dec 2020, I also experience frequent freezes / crashes of the programme after about 2-3 hours of flying. I could only re-start MSFS.

Two days ago, I was also wondering, why again 1GB of data needs to be downloaded as update. It seems it tried to download the Dec update with VR again. After that, i could make a successfull flight.

And then - as said - since yesterday, I only get a black screen :frowning:

I updated the “Gaming Services” in the MS Store. I tried to start from MS Store. I de-installed FSUIPC7, which I just installed a couple of days before. I installed all available Windows 10 updates. I re-started the PC. No chance - black screen only.

I was thinking about de-install and re-installing, but I want to avoid that as good as possible. I guess, I will then loose all my Saitek Cessna Yoke & Rudder settings, which I had to make manually?

Anyone an idea? Thanks.

we know about, and you too if you use forum search function… Example:


=> happens the same magic in your case or we have to search other reasons ( possible login reasons ) ?

Hi @TheWeasel68,
When posting in Bugs & Issues, we only want one bug per topic - not multiples. Most of what you posted has already been posted. Use the search feature of the forum to locate any of your issues and contribute to that topic.

Also, before posting in the Bugs & Issues is to remove all mods, add-ons and 3rd party to see if that is that cause. We only want bug reports on MSFS default content only.

RE: You will not lose controller settings as these are saved in the cloud and will resync on reinstalling or installing onto another PC.

Closing this topic as a duplicate and a multiple bug report.