Freezing when trying to adjust he g3000

Having consistent issues where the stock g3000 is showing incorrect waypoint and the aircraft Cessna Longitude isn’t able to follow the flight path. And freezing for sometimes minutes and sometimes forever, until I close the sim. I have the DakFlight Longitude MOD and nothing else. Prior to this update the mod worked fine.

You should probably contact the author of the mod then. They’ll likely have to update the mod for the new version of the sim.

This has been happening to people with or without mods. It’s not the mod causing the issue.

It seems worse on the Longitude though for some reason. I’ve flown it twice since the update. I don’t mod the plane itself, but tried with both the WT G3000 and without. Both times it froze up on me as well.

I’ve had it freeze up twice in the TBM in about 10 flights with it. Not sure if I was just unlucky to have it freeze both times in the Longitude or if it’s something with the plane that makes it worse.

But in any case, there’s an issue with the underlying G3000 code that’s causing the issue.

Yeah I just made it all the way from KDAL to KLAS. 2/3 times I froze 3/4 of the way there. This last time I did a few things before taking off. I set my nvida setting to performance, made sure my flight plan was properly loaded. I didn’t want to have to alter it mid-flight via the fmc. And I also turned on the massive fan that get me better temps. At some point, I felt it try and freeze but it stopped within a quarter second. I did end up loading an ils from control and it went in fine. I did go direct to that point, it wasn’t added to the plan.

I doubt anything you did made that difference. You just happened to win the “will it fly this time?” lottery.

1 Like

Lost today and big. 6 hour flight from KFAY to EGGL and freeze 20 min from touch down. Happened right when I went to load my approach given by control…

I am not sure this is the same but the G3000 froze but I could continue the flight, in other words the sim stayed alive but the G3000 stopped working…no mods