Fresh install goes directly to the loading screen

So, just reinstalled MSFS 2020 after the update, and now when I open it just goes to the loading screen. It does not ask where to put the download anymore, does not download it either. Just start loading as if it were already all installed. Tried waiting the loading but it gets stuck at around 70%.

Tried reinstalling, erasing windowsapp, formatting disk, reinstalling xbox game pass app, and nothing.

Windows 10

I5 7400, 1660ti, 16gb ram


1 Like

Same issue

did you found anything to fix?

You may be able to force it to where you want it installed by setting your default app location in windows…

Settings > System > Storage > Change Where New Content is Saved. I selected my new blank E: drive

I did this prior downloading anything at all from the Microsoft Store. When I hit install the only thing that went on my C: drive was a folder with about 350 K of config files. My entire sim, including the 1 gig of base files, community folder and all, is on my E: drive.

The xbox game pass prompts me to choose where to install. The game dont. You know that first download when you open the game for the first time? It aint happening. It goes to the loading screen straight up as if the game is already installed

1 Like

Did you solve the problem?

Nope, my friend. Been trying. If I do I’ll come back to report

Nothing from my side aswell

i am having this problema today