FS does not download bing map data

Best of luck getting Asobo to recognize this any time soon. Cache and photogrammetry overall are major problems.

1 Like

There is an assumption that when you say “I activated the bing map download feature” that you are using a manual cache. Is that correct? If so then I assume your internet is too slow. After all that is what manual caching is for. If you are caching manually did you look at the videos on how to set it up?

Or are you saying you just enabled photogammetry and did not change the cache settings? It is easier to know what you’re saying if you use the same terminology as the software uses. Are you actually reading the “current data consumption” value? A screenshot of your settings would make it a lot easier.

Your post doesn’t make much sense in that you say NY looks great but just say “some places” look bad as if no data is being downloaded. If you mentioned what places it would be a lot easier for someone to tell you if Bing data is poor for the area or not.

Oh, to answer your specific questions.

  • Satellites do not necessarily cover every square meter of the planet. I think there are gaps at the north and south polls but I’ve not flown every meter of the planet to have as look. It is a big place!
  • No, it doesn’t happen to me.
  • Yes. Though at times there can be an embargo on specific countries, usually places like North Korea and Russia. I would have thought that if you wouldn’t be able to buy the game at all if there is an embargo.

Thank you for your reply. I activated the feature in Options -> General -> Data named Bing data world graphics and photogrammetry. Please see a screenshot below:

Then I realized that this feature was not working well: current data consumption does not increases, FS does not use network and graphics on the map are bad (by that I mean I can see it’s not satellite images).

I tried to download bing map data manually by using the manual cache because I would like better graphics but the feature did not work too. My internet connection is good enough.

Thank you, I had upvoted your thread.

Perfect, yeah, if you aren’t downloading data with those settings then you do have a problem. they are exactly the same as mine exception my consumption is 189GB.

I forgot to ask if you are using the Steam or Microsoft Store version. The installations are a bit different. Mine is from the Microsoft Store.

I haven’t had an issue so I can’t think of much.

  1. Are you running the game under an Administrator account? You aren’t supposed to have to but a lot of of software seems to say that but needs it anyway. I always do.
  2. Did you try looking - Known Issues - (Last modified: 9/23/2020)
  3. Try disabling anti-virus if you have one running. Windows Defender won’t be causing the issue so thats ok.
  4. Maybe try disabling your firewall.
  5. Maybe reset your router. I have other games that have download trouble if my routers SN ratio is poor which is kind of funny because it only affects some apps. But rebooting it always fixes my issues.

#1 has a good chance of helping, it sure fixes a lot of things. But if not and the other things don’t help then you will need to log a bug report with that screenshot and all the things you tried in Zendesk. They can only work with the info you give them.

Thank you! I tested all including running flight simulator in administrator mode. Unfortunately it did not change anything. I created a post in Zendesk hoping they will find a solution to my issue. I’ll keep this post updated if I get something.

I had the same issue where no data was being downloaded for textures. Go into Xbox Networking and click Fix it. Restart for good measure.

Hi! Thank you! I clicked on “fix it” and rebooted my computer. Unfortunately FS is still not downloading any data.

Same problem…

I have the same problem. The game will download updates, but refuses to download Bing data, live weather and show online players. I’ve been trawling my Windows system for something odd there and can’t find anything other than the Xbox Networking can’t open the Teredo NAT and none of MS’s fixes fix that.

I have fixed this problem for my system. The following might help you.

For Windows Store version of the game (i.e., I can’t confirm for a Steam install)

  1. Open Windows Store

  2. Log out of Windows Store

  3. Log back into Windows Store (make sure you use the account that you were signed into when you purchased MFS or Game Pass)

  4. Log into Xbox for PC

  5. Log out of Xbox for PC

  6. Log back into Xbox for PC with the same credentials as above

  7. Start MFS

  8. Log out of your account from within the game

  9. Log back in to the game using the same credentials as above

Despite being logged into the same account for Windows Store, Xbox for PC and MFS, confusion somewhere within one or more of those can happen (especially after a reinstall of the game and/or Windows) and so won’t allow the game to log into the MS servers that supplies the Bing maps data, etc. Going through the above process resets whatever was stuck.

Will try this!

I’m having the same issue, but Xbox networking shows up as all working properly in windows settings. I’ve tried multiple restarts, logging in and logging out, all without any luck (my data consumption still shows zero. I have the steam version. Interestingly, I can download additional content within the game, but simply can’t get any of the Bing Satellite data to download. Any further troubleshooting tips would be much appreciated! I’ve contacted helpdesk, but who knows how long they might take to get back to me…

Hi guys, any other fixes to try in the meantime? I’m flying in the Netherlands right now and it doesn’t look like the videos at all; in fact the sim is using generic grass fields (not the patches of e.g. tulips we have in the Netherlands) to fill in the blank space.

also not getting any bing data, just the autogen. have tried all the above fixes

Hey!

Since the last update I am able to see my data consumption (I saw it was in the list of fixes) and FS downloads Bing data.

Same Problem here tried everything suggested. Worked flawlessly before the last Update.

It seems like the entire planet is covered with Bing Maps is a deception with a euphemism.

I flew the Tbilisi UGTB - Batumi UGSB route today, and I am so frustrated the ground is only covered with Bing Maps within 10KM diameter around Tbilisi with the rest 99 percent of the flight over ugly FSX texture set :

Tbilisi and environs look amazing but most of the flight was such a disappointment :

I have encountered this problem around klimanjero mountain at Africa. During flight about 10 minutes Bing data lost, then come again. Strange.