FS stuck before main menu in "New World Update" info screen

Updated Nvidia driver today and was able to get past the loading hurdle, started the game like normal. Not getting overly confident though feeling of having “msfsimulatoritis not starting stress syndrome”.

1 Like

Update on my side: I believe the problems were due to the short outage that occurred Saturday May 1. However, one thing that allowed me to load the game even during the outage was to unplug my controllers from the computer and then plug them back in once the game had loaded to the main screen. Not sure why this made a difference…

Tried that and got a CTD - thanks for the suggestion though.

I have the exact same issue. Mine started happening after the so called Windows Update was released and I installed it. I get past the loading screen every so often (but very rare). In order to be able to play the sim I uninstall the app from the computer the 9 or 10GB portion and leave the DVD content on my computer. I then go to the Microsoft Store and reinstall from there then it works (until the next time after I exit then I repeat the steps above. Come on Microsoft come up with a solution!

I’m going through the same thing. It was working fine until the 28th of April. I put it on to play on the 29th and it just stays stuck on the arc de triomphe screen. I have nothing in my community folder too. Very strange.

Mine is now fixed.
I’m using windows 10 20H2 and after installing the latest optional update for this version. MSFS is working again for me.

Still not solved for me, sadly.

Not solved for me either and I am getting really frustrated. I have re-installed twice and it fails at the same spot every time.

I am new here too. I am having the same problem most of you seem to have. I just built a new machine just for MSFS and have never been able to get it to work. It just gets to the New Activities screen then just sits there. I have never seen the sim load fully. Has anyone got this thing to work? Any suggestions? I can’t get this to load and it looks like I just built myself a very expensive email machine. :frowning: Any help would be appreciated!! :+1:

1 Like

If anyone comes across this post… problem solved. I actually got the idea from another poster on this forum. The problem is not my machine. The PC I built is fine. The issue is with Microsoft, and possibly Osobo. There is a server error causing the load and startup of FS to hang. The solution is simply to unplug from the internet and reconnect. That’s it. Just unplug the RJ45, wait a second then plug it back in. This is only a work-around. Hopefully MS fixes this soon. But for now this does the trick. Cheers.