FS won't launch when RV is connected (Reverb G2)

Hi, when I try to launch FS with the headset connected the game won’t launch and stays loading forever. If I try to connect it once I’m already inside of FS it just frozes and I can’t do anything anyway. This morning I was able to launch it smoothly but without any sound after two days trying everything. I configured the keys to enter VR mode and I went to have lunch, but when I tried to launch it again this afternoon it happened again and I can’t even enter the game.

I have already tried nearly everything and I can’t figure where is the problem: The computer is more than powerfull enough to run it in VR and the headset works perfectly when I try games from the microsoft store or steam and I have been able to make DCS world work but without sound.

I’m already out of ideas: Does anyone know what more I could try? I haven’t find anything on the internet about people not being able to launch the game with VR connected and all the information seems to be about what to do once you are already inside of the game.

Thanks beforehand.

1 Like

Hi, there is a USB issue, change port or buy a new PCIe USB HUB.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.