Fs2020 airbus everything shut down mid flight

Not quite the forst post I had in mind…

So there I was, minding my own business at FL350 enroute EGPH to LEPA when everything shut down. The whole aircraft went dark… Flight controls still worked but no power or navigation or any other system either. Tried the shortcut to auto start the engines but stil nothing. Needless to say it did not end well…

Running the flyby wire A32NX mod but its been fine until tonight.

Anyone else had a similar issue? This is not the left engine issue.

Maybe Brexit spies have sabotaged the Airbus? :wink: I’ll go try the Boeing meantime.

Regards

James

** Looks like I missed the other thread with the battery/apu issue.

1 Like

Same here. My A320 dies mid flight and every buttons seems unresponsive

Enable generic plane models for AI and multiplayer.

1 Like

Hi has this issue been resolved, as I had this issue for the first time now for around a week this being January 2021

I am having the issue of the Airbus 320 crashing my machine as well as of today 20 January 2021. This is strange for I have a pretty powerful machine.

I hope this issue is resolved soon.

Can you describe what was happening when this occurred?
Look at this thread.
At the bottom of it is a section on simconnect.
This may offer some help.
Let us know!

Hi,

I was just flying along having gotten to FL360 on Airbus from TAPA to KMIA; CTD

It also did it about 20 minutes out of KMIA to KDCA and just at take off in the same route; CTD

I tried to use the Cessna Longitude for the KMIA to KDCA flight and before I could take off CTD.

I now am beginning to think it has nothing to do with the Airbus at all.

It is strange, because a week ago everything worked flawlessly.

Neil

It doesn’t.
It is the simconnect issue mentioned above.