FS2020 crashing with Simconnect since last update

Hello Gang. I never had any crashes before the last update and now all of a sudden, I am starting to get these crashes (image attached). Has anyone else experienced this?

Thanks!

1 Like

Are these longer flights?
It is not uncommon lately in longer flights.
I have seen posts here saying that turning of Bing Data has helped with this, but no one seems to have found a cure-all for it.

1 Like

Could be helpful to know, if MSFS is the reason for the crash and SimConnect just fails afterward. To check this, press the Windows Key + R, type “eventvwr”. Let it load and open the error tab. There you can see, what happened at which time and what´s the exact cause for the CTD. You will get an error code you can provide for us. Important: Search the SimConnect error and the MSFS error and check at which time they occurred, so we can see which error came first.

2 Likes

Hey EpicPrimus. Thanks for your willingness to help. When I pull up my event viewer, the attached image shows what I see. I don’t see an error tab anywhere. Any ideas where to find the info you indicate? Thanks again.

1 Like

Expand the Custom Views selection on the left.
Administrative Events is the first thing in that folder.

OK Thanks. I hasve attached an image of the error. Looks like MSFS might have taken a dump???

1 Like

That error does look to be the same mystery issue that causing a lot of CTD’s.
It is the sim that’s crashing.
Were you on the sim when that earlier error that is shown came in?
If so, what is it?

Hey DMullert,

the cx0000005 error is a memory access violation problem. Make sure to start your MSFS always as administrator.

I would try out the following things:


Reinstall Visual C++

  • Press the Windows Key + R, type “appwiz.cpl” and then press Enter.
  • Locate the Microsoft Visual C++ programs on the list.
  • Select each entry and then click Uninstall.
  • Download a fresh copy of Microsoft Visual C++ from this page and then install it.

DISABLE CPU & GPU OVERCLOCKING

We advise against using overclocked systems to play Microsoft Flight Simulator. The increased voltage causes overheating and can gradually damage your computer’s hardware (CPU, GPU, RAM, and motherboard).

If your system is overclocked:

  1. Disable Intel Speedstep on your Bios overclock menu
  2. Lower or disable your CPU overclock values
  3. Disable GPU overlocking for your Microsoft Flight Simulator game profile on Radeon Software or Nvidia nTune (this applies to custom user overlock settings, not for factory overclock settings of the manufacturer)

Please refer to your manufacturer’s guidelines regarding how to disable or lower the overclocking speed of your CPU and GPU.


INCREASE THE VIRTUAL MEMORY (PAGEFILE) ON YOUR SYSTEM

  • In the Windows Seach bar, type Advanced system settings and open the Control Panel.
  • Make sure you’re on the Advanced tab.
  • Click the Settings button from under the Performance
  • On the Performance Options box, go to the Advanced tab > Performance
  • Click on Settings
  • On the Virtual Memory box, uncheck the Automatically manage paging file size for all drives
  • Click to select the drive on which Windows 10 is installed (by default C:)
  • Click to select the Custom size radio button.
  • In the now-enabled fields, type the minimum and maximum size of the Pagefile in megabytes (MB) according to the physical memory present in your computer.
  • Click Set and then click OK.
  • Restart your computer.

Add MSFS as exception of Windows Defender

https://support.microsoft.com/en-us/windows/add-an-exclusion-to-windows-security-811816c0-4dfd-af4a-47e4-c301afe13b26

Here is a screenshot of my folder, I added to the exceptions. Locations can be different.

//edit:
How much RAM you got installed and what is your hardware in general?

2 Likes

Wow - Lots to digest. I have 64gb of RAM. Here are my specs:

System Specs: Motherboard: Gygabyte Aorus Z390 Master. CPU: Intel 9th Gen Core i9 9900kf Eight-Core 3.6Mhz overclocked to 5Mhz. Memory: 64GB Corsair DDR4 SDRAM 3200MHZ RGB. GPU: 11GB GeForce RTX 2080Ti FTW3 Hybrid. Monitor: Viotek 34" curved GNV34DBE. Power Supply: 1000 Watt Power supply. HD 1: 1TB Samsung 9780 EVO Plus NVMe SSD. HD 2: 2TB Samsung 860 EVO SATA SSD

Flight Sim Hardware: Joystick: Thrustmaster T16000M. Rudder Pedals: Thrustmaster TPR Pendular Pedals. Yoke: Honeycomb Alpha. Throttles: Honeycomb Bravo.

1 Like

Ok, the hardware looks good and is more then enough. MSFS can be a little bit bitchy, when it comes to OC.

1 Like

Yeah I know. I bought my rig from Jetline Systems and I just let them do their thing and do the OC’ing based on their knowledge of MSFS. I don’t tinker with that stuff - LOL.

1 Like

Please be careful with these „start flightsimulator as Administrator“ tips. It is not necessary and dangerous by the way. Addons can be downloaded from anywhere in the Internet. Malicious addon code then runs with Administrator privileges and can really do freaky stuff with your computer. I downloaded the goose from a google drive share. This addon is perfectly fine. But there could be mad people with other things in mind :slight_smile:

1 Like

Agree with that, but isn’t it much more about making sure that you don’t download any malware? So, if you keep your files safe, there shouldn’t be a problem with starting as administrator. If you are getting bad files, they can possibly hurt your system even before you started an application unregarding the administrator thing.

2 Likes

There are a few threads talking about this already. I get this occasionally, mainly when I end a flight and am trying to return to the main menu. About a 10% fail rate for me. Don’t know of any solutions, although Asobo did mention somewhere they were going to fix it, but I’m not sure if that was in world update 3 or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.