FS2020 not seeing joystick anymore

No problems yesterday, boot up FS2020 today and my joystick isn’t seen in the game anymore. Windows sees it, my drivers see it just fine, other games see it, but I have no joystick option in FS2020.

Rebooting and reseating connections didn’t change anything.

Anyone else experience this?

  • Unplug the affected controller(s) before opening up the sim.
  • start the sim
  • at the main screen, plug your controller(s) back in.

Tried that, no go.

Also just uninstalled and reinstalled drivers, no change.

Does Windows recognize your controller? Have you tried connecting into different USB ports? If you’re using a hub, have you tried directly connecting to the computer instead?

If all those things fail, there’s also the possiblity your controller may have died.

Windows sees it just fine, tried different USB ports, no change there. No hub, directly into a port in the back.

Thinking the controller died (which it hasn’t, works fine in DCS), I plugged in an old Sidewinder Precision 2 that I was using till the hat switch broke, and FS2020 doesn’t see that either. Just keyboard and mouse.

This is for sure an FS2020 problem

Have you tried turning it off and back on again? lol
(sorry, couldn’t resist)

Have you tried rebooting the computer.

Well, if that doesn’t work, I’m out of ideas then. Sorry dude. Normally that first solution I posted takes care of it. I hope you get it working or someone else comes up with a solution for you.

Solved it. It was a conflict with Steam Big Picture, believe it or not. Zendesk to the rescue

1 Like

Glad you got it sorted. Happy flying.

What is Steam Big Picture?:thinking::sweat_smile:

It’s the interface you use if you were to stream games from your computer, to your TV.
Works pretty good if you have a wired connection for everything and have something that could be played with a controller.

Got me too. Maybe coincidence, but unplugged,rebooted a couple of times and replaced the stick. For me, it seems that it was a USB issue on the computer, though the timing was very suspect. After 30 minutes of faffing around, all was back to normal, although my rudder sensitivity had changed back to default.

What kind of joystick? Sidewinder?

Logitech G940

That’s the trouble with software development. No matter how careful you are, there will always be some combination of hardware, external software, settings, user and weather which manages to break it.

You’ve got to have at least a little sympathy with Asobo.