FSDreamTeam GSX for MSFS

I think i solved it by uninstalling better toolbar by scriptless from flightsim.to.

Do you happen to also have it installed?

No i just have Pushback Express installed but not running… I figured out that my CTD happens when opening the assistance menu from the MSFS toolbar from the time on boarding is started. So nothing wrong with the pushback at least for me. Still no luck solving this problem. I’ll give a complete reinstall a chance now.

Did you solve your problem? I have exactly the same issue. Reinstalled GSX, FSDT Installer, etc… with no luck. CTD (memory could not be read) happens after clicking on the assistance button in MSFS toolbar when boarding is progressing.

It seems to be happening with the Fenix only. And only on the ground after boarding and deboarding. Tested it with the CRJ and 737 and the crash didn’t happen. When it’s working I find it an amazing addon btw.

I guess it has something to do with the manual entry to not disable the assistance menu in the Fenix flight model. Going to try deleting the entry entirely and see what happens then. Gonna report back tonight.

Can confirm that this is happening with the Fenix only. Tried to remove the disable_assistance line in the flight_model without success, still CTD… I’m waiting for account confirmation in FSDT forum, will post this bug over there…

I’m with you that GSX is a very good addon, especially if the SDK implementation for reading data from encrypted airports will work.

1 Like

I installed it on the 22nd.
Had 3 CTDs in the Salty 747 and 1 CTD in the 787.
Managed to complete an 8 hour flight in the PMDG 737 though.
Uninstalled GSX and now no crashes in any aircraft.

It seems with some aircraft GSX causes MSFS to crash and yet some aircraft it doesn’t. I hope FSDreamTeam or Asobo can sort out whatever is causing this memory error because I really want to use this Addon :tired_face:

1 Like

Just use ALT-TAB and close the editor window. It can happen with all 3 Config Windows. They dont stay on top. So if on is open and you click into the simulator, the window got behin the sim, but is still open.

Yeah tried this but didnt work.

If something gets “stuck”, hit the WIN key to expose your Windows toolbar, right-click on the Couatl app in the tray and restart it.


FWIW, just now I received approval for the FSDT forums, not quite 6 days after I applied. So those of you still waiting for approval, it looks like they are finally getting around to it.

2 Likes

Thanks you have been very helpful.

Has anyone tried thos mod with HW A330? I keep getting park brake must be applied to start GSX even when applied.

I read about the parking brake issue with regard to a different plane over on the GSX forum - if the plane’s code uses some customized internal variable name for the brake status, GSX has to “know” what that variable is and how to read it. Same thing for doors and hatch open/closed status and the commands to open or close them. I expect stuff like this will get sorted out in time once the dust settles and people are able to start creating profiles.

Right now, everything works pretty greast in the PMDG 737-700, but the -600 isn’t compatible (and the plane editor isn’t saving stuff properly for customized personal profiles). With the -800 due for release any day, the same situation is going to apply there too.

1 Like

Thanks once again!

This is driving me insane.

Has anyone managed to get boarding working with an embedded stair (such as the Twin Otter)? As far as I can see everything is as it should be but no-one wants to board :face_exhaling:

lucky you that got the approval. Have been waiting from release and used the GSX only once as it crashes the toolbar when I switch to VR which is lame.

To be honest I don`t know why I did not request a refund yet. I just gave another 2 days.,…

Posted this 4 days ago.

1 Like

Something’s not right somewhere. I’ve got the door and the embedded stair set up correctly but when I request boarding nothing happens.

If stairs are there people come out and climb them. It’s doing my head in!

I should add all the walking points/gates/parking spot etc is set up correctly.

1 Like

anybody know if its possible to customize pax walking through the jetway and into the aircraft?

They are hovering 2m above the ground and are poking through the ceiling.

Also, I am getting double spawnpoints when I replace the jetway on my third party ENGM airport, anyone know what I am doing wrong?

Went to test it out again, and it defaulted to the original X and Z door axis. ???. Spent a few minutes trying to reconfigure. It doesn’t seem to be holding. The numbers are not saving in the gsx.cfg file for the TwinOtter. Finally got it working again. Don’t have faith the it will hold. Maybe after reboot it’ll fix itself?

1 Like

I spend two hours fiddling with it this afternoon. This product is not what it used to be.

What worries me most is all those profiles on flighsim.to right now, the community taking over but only adding a few gates here and there. In the old GSX version this was all well programmed and you wouldn’t need all that sort of manual programming.

Regardless, it doesn’t do anything right now. Can’t get it to board, deboard, not even add stairs before programming them there first. This is a flightsim, not an engineering sim. I do hope they’ll show more ambition in the near future but for now I don’t find it enjoyable.

4 Likes

I don’t think GSX is configured for GA aircraft yet for Pax. I ask Umberto about this early on in the development. it will come in time. but not right now. I’m glad I can do pushback and refueling on GA for now.