G1000NXi not meeting allitude

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Using the G1000NXi it levels off before reaching altitude usually within 200ft of target.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I don’t think we’ve seen this reported before. Do you have a video by any chance of this behavior and how exactly it is you’re engaging ALT mode?

According to your screenshot, ALT was captured intentionally at 11360 feet in the FMA, so it appears to be holding the altitude it indicates is captured. Definitely going to need some more details on how you’re getting into this state.

Set up AP before take off (my procedure). This has been happening every time since last update. I thought I must be doing something wrong.

Still going to need some more information. Are you climbing in PIT, FLC, V/S? Are you manually pressing ALT at any point in the climb? Does the AP automatically go from your climb mode to ALT on its own, and do you see the yellow mode change flash?

1 Like

Caught it with video let me figure out how to send it up

That does look strange, let me see if we can reproduce it. Are you running any mods for this plane?

No I am completely stock while we go through SU10 beta’s

So, I’ve tried this exactly as described and as in the video, both with and without the G36 mod, and I am unable to reproduce this issue after a number of tries. Perhaps other users can chime in.

I have deleted both G1000’s and reinstalled. Still got the issue. Have a video of the same in the Cesena 172

Are you using 1.27.13.0?

It looks correct here, at least on SU9, perhaps only a SU10 Beta thing … ?

Watching the video, did you use an external device to dial in VS ?
How is set weather : static / in-sim live / external addon ?

I’ve tried to change VS using my Honeycomb Bravo and with mouse only.
Weather is in sim live but I’ve tried static
Maybe it’s a 1.27.13.0 thing.

Have you tried without the Honeycomb wired, in any case ?

Tried the stock G36 on 1.27.13.0 with live weather and cannot replicate this.

Are both the altimeters set with the same baro setting? Wondering if it could be a discrepancy between the G1000 and backup altimeter settings.

Just to make sure – you’re not manually pushing the ALT button on the Bravo when it gets close to the target, are you? It’s completely hands-off?

No It’s completely hands-off

I have uninstalled/deleted both the G1000 and the NXi. The G1000 reinstalled fine.
Un plugged the HC Bravo
This happens in the C172 and the Beech G36
No matter what altitude you choose
with 2000’ it will stop on it’s own at 1920
with 4000’ it will stop on it’s own at 3820
with 6500’ it will stop on it’s own at 6420
I’m wondering If there is more folders than the workingtitle-instruments-g1000

1 Like

Yeah that’s danged odd! I’d suspect inconsistency in the barometers too but the details are beyond me. I’ll leave it to the pros. :smiley:

You said “THEY reinstalled fine”. Does that mean you installed both the default G1000 and the NXi?

As far as I know you have to delete the default G1000 an install only the NXi.