G1000NXi not meeting allitude

Yes, since we are in the SU10 beta forum, I tested this on the current live SU10 beta version.

Sorry I mis-stated.

  1. Uninstalled NXi , shut down and rebooted.
  2. Deleted the workingtitle-instruments-g1000 folder then started FS
  3. It installed G-1000 while booting
  4. jumped in the 172 and still have the problem.
    I am running the beta.

Hi @meh1951
Wow, you can find the oddball cases! Sorry it’s an issue. I’ve tried multiple variations of flying the plane setup and can’t seem to duplicate the issue. I’ll keep looking at variations of the setup that might cause the issue. But so far, no joy!
Regards

1 Like

Same here. Captures ALT mode and then levels of on the exact altitude. Tried on various (172, DA40, DA62) planes and all worked as expected.

Good thought but no


I’ve observed this for the first time today, but only in a situation where I’d changed between live weather and clear skies whilst climbing

I do nothing but live weather

Could you try again, with at first moving temporarily all Community folder content to elsewhere (in a backup and safe place), before starting MSFS ?

Nothing in my Community folder

Don’t think it’s 1.27.13.0. I just installed the G36 Improvement mod and the Garmin worked with no issues using both the Bravo inputs and the in sim inputs.

On an unrelated note, is anyone here by chance using or has used either the stock G36 or the G36 Turbo mod with the NXi? Neither the PFD or MFD will power up in 1.27.13.0. I know they were working in 1.27.11.0. I was going to check them out to help with this issue and noticed the problem. Anyway, not necessary to reply, it’s the the topic of this thread.

I can however confirm that the NXi is working with the G36 Improvement mod in 1.27.13.0 on my system at least. Hope you can find what’s wrong and let me know if you need someone to try things to help you.

yes

GitHub - roblenvic/Bonanza-Turbo: Turbo Engine, Lighting mods and Custom Flight Model

It looks like the mod have been designed up to SU6, things have changed a bit since …

Tank you. I’ll check it out.

Appreciated.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

I have the same happen with the Bonanza Improvement mod, the Bonanza Turbo mod, and the stock Skyhawk G1000 so far. Still testing others. Plane levels off at whatever altitude it’s at when ALT capture engages, doesn’t continue climbing to the altitude set in the selector.

If relevant, provide additional screenshots/video:

Microsoft Flight Simulator 8_8_2022 5_11_08 AM (2)

Quick question, you are able to use the NXi with the Bonanza Turbo mod (and default Bonanza)? I have reinstalled the Turbo a couple of time, no luck.

I was able to use the NXi with all 3 versions with the last beta. However since the update to 1.27.13.0 I cannot get the units to power up (black screens) in either the Turbo or default G36. It is working in the G36 Improvement mod on my system.

I know the Turbo has not been updated in forever but I’m wondering what might have changed to cause it to die between 1.27.11.0 and .13.0.

Right, I am aware “…things have changed a bit since…”. However I’m wondering why they changed within the past few days. The NXi was working fine in all versions of the G36 on my system in the last beta. Since updating to the latest beta, only black screens.

Thanks.

This is the purpose of ALT HOLD, if “ENGAGED” as stated, so we have to release ALT HOLD if we wish to pursue climbing or descending

Could rather be a graphics driver issue, check if updated to latest and no custom settings made on driver side …
Are you on Geforce or Radeon ?

Edited my post to read “capture”.

Looking at the screenshot, it looks like the 5000 ft is reached and ALT HOLD become active, which is a standard behavior
To go higher, we have to set the next altitude to a higher level
If I want the autopilot to follow the vertical path for me, I just set the highest flight level in the flight plan
Be aware on standard aircraft without autothrottle, the VNAV is not available if related components are not installed in the compatible aircraft like in RL. In flight simulation this could only be an “artificial” behavior otherwise