G2 Reverb, sound yes, video no

Searched the boards, but I have a Reverb G2 and I launch MS Flight Sim and it auto loads Mixed reality portal and when I launch MS Flight sim, I hear the audio, but I stay on the Mixed Reality screen in the goggles. I select change to VR in game, nothing changes. Please don’t beat me down for asking something what might be simple, but cant seem to figure this out. :confused: Help?

I don’t have VR but did you use the “switch to VR” keybind?
Does it work in other VR games?
Do you have an AMD system and if so are you using the AMD compatible cable? I think it was a G2 where someone yesterday said they were told to buy the correct cable when they had no video. You would have to search to check.

Hi @Gomama231, Does pressing Window Key + Y help? This should switch the input to the WMR portal. What is showing up on the Mixed Reality Portal screen? Or once in the sim, CTRL + TAB.

Hi all, yes, I do the “Windows key + Y”" and mouse control goes away, but I am still in the “Mixed Reality House” and does not change to Flight Sim. I have Intel® Core™ i9-10900K CPU @ 3.70GHz 3.70 GHz and 128 gigs of ram, so I am thinking the system is beefy enough. Still no luck, but I can hear the audio in the headset. (sigh) Its gotta be something silly I am missing…

Ensured all drivers are updated, turned machine off/on, ensured Steam is not running, I launch MS Flight Sim, it launched Mixed Reality fine and I hear the MS Flight Sim audio in the G2 Headset and something I also noticed, I dont have all the menu items people seem to have with the new patch in MS Flight Sim, I have a VR tab at bottom and that’s all, I see on the videos there is another menu that I dont have, which makes me wonder if something is not loaded that should be?

@Gomama231, regarding the missing VR Graphics menu, I believe in the release version it was incorporated into the main graphics tab. That’s why some of the videos recorded on the pre-release version have that additional “VR Graphics” menu tab. Am not 100%, but that is my understanding. There was a thread here that touched on that a little bit.

Still trying to think of why it isn’t swapping from the WMR “House” to the sim…

Have you installed OpenXR?

Hi Zeefly, according to MS it is installed: WMR (WINDOWS MIXED REALITY) HEADSETS <–it bolded this, I was not yelling :slight_smile:

No action needs to be taken if you are using a Windows Mixed Reality headset.

I will look into seeing if it is/or is not, checking…(fingers crossed) :slight_smile:

By default, press Ctrl tab to enter VR mode.

CTRI-TAB is done and my mouse control goes away, but still in the WMR house…with MS Flight Sim audio in the G2 headset.

@Gomama231, just to confirm, here is how I swap once I have the WMR “House” up… Window + Y to allow normal desktop input. Then I Alt+Tab over to FlightSim. Once in sim I press CTRL+Tab to Enter VR mode in the sim. (Sounds like you are doing that, but wanted to mention the steps on my end. Also using a G2)

@JuiceBox7535 Yes, that is correct, I just used your list as a check list and I remain in the “house” :confused:

I also tried changing to VR mode in the options menu, I hear the menu being selected, but no change to visual.

Ah, that’s frustrating! I thought it would be something simple. Maybe someone more familiar will jump in. Only other idea is to uninstall and reinstall WMR:

  1. Disconnect your headset from your PC.
  2. Close Windows Mixed Reality Portal.
  3. Go to Start > Settings > Mixed Reality and select “Uninstall”.
  4. Restart computer

When you’re ready to start using your headset again, plug it in, and Windows Mixed Reality Portal will take you through setup.

@JuiceBox7535 I will do it now, I did not take 9 days off for the holidays, I took off to play MS Flight Sim :)…my large monitor is nice, but its not VR :confused:

1 Like

Just to check, you definitely have a bind for toggle VR set? If you’ve had any custom binds it won’t populate automatically.

You can set a binding for toggling VR and re-centre view in the normal control binding menu - just search for VR and you’ll find the options.

Open Microsoft store and search for openXR for mixed reality devices, install. Optionally open it and Go to dev options, tick use latest runtime.

If still not working and you definitely have a bind set up for enter VR try uninstalling the headset (device manager, wmr headsets, remove device) reboot and then re-install.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.