G3000 Nav is broken after SU6

Hi together,

the G3000 Planes (TBM 930 and King Air) AP Nav seems to be broken since SU6.

The Planes fly just circles when AP Nav is activated and Distance to the next WP is always displayed as 0 NM. That happens with VFR or IFR Flight Plans as well as with direct to Navigation during a “free flight”. Anyone experiencing this Issue too?


had 2 TBM fligths today first on TBM not modded and second with TBM modded WT G3000 and no such problem AP was working fine

I did an IFR flight on the stock TBM yesterday and the AP worked perfectly (SID, STAR and APR).

Maybe its a issue of the Region? Where have you been flying?

I had this same issue a few times in various aircraft (B787 & TBM). The issue stopped after restarting my sim but experienced a non-stop right turn.


Are you using the Working Title G3000? It’s highly recommended.

There is no working title g3000 on xbox till now

1 Like

Hi, exact same thing happened to me on the 787. In addition groundspeed display is always 3 kts

1 Like

This is happening to me also. When engaging the autopilot it does not follow the course, it only goes around in a circle. Was flying the A320 and B747 in Colombia.

1 Like

For me it occured the first time now with SU6

1 Like

PFD artificial horizon froze and distance information
MFD whole screen froze
Couldn’t turn off brake warning bell
could not activate taxi light

Well, this has been my experience with SU6…

And, I don’t know if this should go to 3rd party addons or here… but here goes…

First off…the graphics are fantastic. The FPS is great. Smoothness of controls are great.

I am flying the TBM930 with the WT G3000 in community folder and that is all.
So… big Kudo’s to Asobo.

Now the not so good…
And I don’t know if this should be addressed to Working Title or here, but I’m posting it here.

  1. The artificial horizon on the PFD froze (only works with synthetic vision)
  2. The whole screen on the MFD froze
  3. could not turn off audible warning for brakes
  4. could not activate taxi lights
  5. could not activate pulse lights
  6. when you activate ‘Direct to’, no active vector is drawn

I know that the PFD and MFD issues are probably Working Title issues. But, what about the warning alarm and taxi lights, and pulse lights?

I still consider this a huge success overall to Asobo… Big Kudo’s and thanks for your hard work!!!

1 Like

This is happening to me in A320, 787, 747. Had heard of this issue before SU6 but I had never experienced it with the exception of activating an approach late. Now happening every flight immediately after takeoff. FYI I’m on Xbox series S.

Just closed sim and restarted console, now A320 is LNAV’ing fine. Not sure what the issue is.

1 Like

a friend had this with an A320 on Xbox yesterday.

I can confirm that the G3000 AP (stock, no WT mod) is randomly broken in the following ways:

  • First off, following a flight plan filed in the pre-flight config screen works as before.
  • Without flight plan, ad-hoc entering Direct-to does not work anymore, the AP makes the plane just fly circles.

  • Selecting a STAR procedure in from the list in flight does not work anymore → same behavior, plane flies circles or bogus headings, this also happens when a flight plan was filed and ATC assigns a different transition so the plan needs to be modified.

  • When that condition happens, the AP can’t even do a simple ILS-approach anymore, yesterday I set it on the LOC like 20mi out (after giving up making it accept a simple DTO) and it locked on the LOC for a while but then deviated to the left and started helplessly meandering around it (with a headwind pretty much on the nose).

Trying to replicate this from a fresh flight doesn’t work, it has yet to be investigated if that always happens after some time or just sometimes.

All these things worked consistently fine with the stock G3000 in the TBM pre SU6 only days ago, on the same route and airport(s).


Version (latest update, installed earlier this week).
TBM 930, with no mods.

Flight plan included a segment from HELSI to FETAR (southern California, San Diego to Palm Springs). This segment showed as HELS → TIME on the PFD.

Distance DID count down correctly, BUT upon reaching FETAR, the aircraft turned AWAY from the airport, flying a reciprocal to the heading it should have been on.
There are no mods at all in this installation.
Anyone else experiencing anything similar?

On top of all of that If I change the flight plan In mid flight aka Direct to somewhere else the new flight path will not load. Also the altitude and airspeed freezes. The only way to fix that is to restart the flight. It’s for sure broken.


What I found is if I flew an aircraft using the Working Title (WT) G1000 NXi, then start a new flight using an aircraft like the 787, LNAV will not work, navigation breaks. No waypoint cycling, 0nm distance displayed, 0 ground speed, etc. When I close the sim and restart, everything works again.

I have a similar problem, but with Xcub (and other G3X planes, haven’t tried g3000 yet). After flying a plane with WT G1000, creating a new flight with say the xcub in a different area, the nearest airports would always show the previous area. HSI would be frozen and can’t set VOR frequencies, etc. Reinstalled the sim without G1000nxi and it works fine. Seems working title mod is messing with the other avionic systems. This never happened to me before SU6.

My theory that this never happens with a flight plan created in the flight config screen just went overboard: I created a simple A to B VFR plan and the G3000 in the TBM malfunctioned right away. The telltale sign showing up early is the “0 KTS” GS indication and indeed there is no way to fix that (just took the opportunity to try what could be done and used the gang bar over the Master switch but the AP doesn’t lose its memory that way and doesn’t reset.

I can confirm that, happens with the G3000 and the G1000NXi too, if you hit that button for a second time it shows the first “nearest” waypoints it displayed. Only when you hit it once again after some time it had updated the list.

Well, once again they repaired stuff on several planes of the fleet and they all came back with defective avionics. Sounds like they learned their craft in the 70s at Renault and British Leyland. :slight_smile: