Game crashes to desktop when building package

I have created about 10 airports using the SDK. Eight of them are working fine but I have a couple that are crashing to desktop when I build the package. It’s not happening the first time I build the package either. It may be after the 10th or 15th time that I worked on the airport and the builds went successfully before that, but all of a sudden it starts crashing. I opened 2 tickets (one for each airport) with Zendesk but just checking to see if anyone else is having this issue. It’s pretty frustrating to work for several days and hours on an airport then have it suddenly CTD when building the package. I thought it might be related to a custom model or two that I created but there is no common denominator. The airports that are crashing are 90% models designed for that airport only and the other 10% are common models shared across all airports and those are working on the other 8 airports. I uploaded the event logs to Zebdesk but they don’t really tell much, just that the app crashed.

1 Like

I’d check if ALL of the models are UV unwrapped. Had a ton of issues with this.

I think I have found the issue. I have a model that I created for P3D but am using in FS2020. The model is an airport parking T. It has the yellow stripe and then small concrete pads at each end for the tie down ropes. The rest of the area of the graphic file is transparent so that you only see the yellow stripe and concrete pads. I placed this model and to prevent flickering I raised it .15 of an inch. This worked okay in P3D and they looked good. They looked good in FS2020 but on some airports they caused this CTD on package build. Of the 11 airports that I have made for FS2020 that use this method, only about 3 or 4 of them are experiencing CTDs. The rest that use this model are not. I removed the model and texture of the 3-4 and I can now build with no CTD. I switched to using the graphic file as a new material in FS2020 and add that to a small apron. It looks the same in game but doesn’t CTD. I hope they add better error handlers and traps in the future.

As a side note I added a step in to my process. After each build I make a copy of the airport. That way if I experience an issue I can always roll back to the last successful build.

I’ve had terrible problems with the BGL compiler in the SDK. For example, when you “Save Scenery” for any custom airport that has an ILS, the Save Scenery command is putting the Range and Beam Angle in the wrong place in the XML file. When you click the Build All command, MSFS instantly CTD’s. It took me a whole day to ferret out the problem. I sent a bug report to Zendesk, and they were already aware of it.

Same thing on my end. One version of MSFS will work great… the next constant crashes. I’ve tried emptying out my entire community folder and still crashes on compile. I wish I could figure out the issue

I have the same problem. When I click Build Package - the game freeze up for 3 hours 14 minutes - then CTD with no error message ro crash log.

If anyone know a way around this prob - i’d be grateful to hear it

Same issue with the december 22th update + have to reinstall MSFS every time
I have no custom 3D model and the scenery is only consisting of a simple runway and a windsock

Same problem with SDK 0.9.0 and 1.12.13.0 Very simple project, just BGL + ArtProj, hit Build Package and FS CTD breaking the installation, which requires to repair the game from the Apps Store every single time…
Wondering if console’s log is stored somewhere to check what’s going on here…as I have no other way to check on the error while building, as it crashes inmediatelly.

you can repair from MS store ? you don’t have to reinstall the software ?

In my case from MS Store I have no other option than “Reinstall”. When click on reinstall it asks for installation drive (I have multiple drives), I select the one where FS2020 is currently installed, and it just repair the installation, it does not download the 130Gb again. It took no more than few seconds to process, but it’s annoying though.
Never tried this, but from MS Configuration -> Applications if you select Microsoft Flight Simulator, you’ll see there’s advance options, and from there you can repair the app.

i tried your method but since I don’t have another extra 130gb I can’t fix it from Windows App Store

I created my first airfield today and i also have the problem that the sim is crashing when building the package and then its completely broken. I have to copy a few files to my backup hdd to get enough space on my ssd to reinstall the sim again, then copy the files back, so i dont have to redownload everything. This always takes about an hour which is pretty annoying. I downloaded the SDK today and have everything else up top date. Is there any solution for this?

I was trying to re-do and update some of my scenery creations for flightsim.to earlier this week but I gave up because there seemed to be issues with SDK. It just doesn’t seem very stable right now. I was experiencing a lot of crashes with it.

My view is I’ll come back to it in a few months once things have settled down a bit. Reading around here others seem to be having similar problems.

2 Likes