Game freezes every 30 seconds as GPU load drops from 100% to 0% then goes back up to 100%

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

I have uninstalled MSFS, removed all content under Packages, reinstalled MSFS as a clean install with no addons.

Are you using Developer Mode or made changes in it?

No.

Brief description of the issue:

MSFS is drawing 100% load on the GPU (even in main menu). After starting a flight the GPU drops from 100% to 0% (causing a stutter) and goes back up to 100% for another 30 seconds. This behavior persists consistently and always 30 seconds between each stutter.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

Start MSFS.
Start a flight.
Wait 30 seconds.

PC specs for those who want to assist (if not entered in your profile)

CPU: i7 6800K 3.40GHz
GPU: 2 x GTX 1080 SLI (though issue persists even when running each GPU individually)
RAM: 32GB

Did you submit this to Zendesk? If so, what is your ticket #?

Yes. Ticket # 94764


Behavior persists;
— Regardless of graphic settings (tried Low-End and Ultra, and same result)
— Regardless of online setting (tried rolling cache on/off, deleted cache, tried manual cache on/off, tried connectivity turned completely off)
— Regardless of GPU configurations - Tried each GPU individually and in SLI and same behavior.
— Regardless of Refresh rate, VSYNC and Frame limiter - tried VSYNC and frame cap at 20, 30 and 60, as well as no frame limiter. Also tried setting monitor from 144Hz to 60Hz to match VSYNC 60fps. No difference.
— Regardless of which monitor game runs on - Tried changing it to windowed mode, shrank the window to smallest possible size and moved to second monitor. Stuttering persisted every 30 seconds, although GPU load went down to 45% and temperature was at 65°C which eliminates this being temperature throttling in the GPU.
— Tried turning off anti-virus, anti-malware and adding .exe file for flightsim to firewall exceptions list - no difference.

— Have been running other games at similar GPU loads and no other game has this behavior of dropping load to 0% every 30 seconds. This issue is exclusive to MSFS.

— Issue started happening early this week (spent 2-3 days now trying to troubleshoot the issue to no avail.

— Been playing MSFS for 600 hours since launch and not had any issues until now.
— PC hardware has been unchanged since 2017 with no issues like this in the past.

For your system, is it normal that the GPU is loaded at 100% constantly?

Have you recently updated nVidia drivers? Perhaps have a go at running DDU and reinstalling the drivers from scratch? Might be worth a shot.

It is odd that it’s at 30 second intervals… which would normally point towards something service or polling related in Windows, however if it’s not normal that you GPU is constantly loaded at 100%, it would appear to point to something GPU related.

I have the latest drivers from Nvidia 461.40 which I installed when it was released, so I played for several days with new driver without issues.

That said I have re-installed the driver just in case.

The GPU isn’t normally loaded at 100%. In other games it will be running anywhere from 45% to 100% depending on game and depending on how much stuff is going on in the game / on screen. In MSFS though it’s loaded at 100% even in the main menu, and even if I set the VSYNC to 20FPS to reduce the load. The only way to reduce the load from 100% in MSFS is to go windowed and shrink the window down. Then the load drops lower, to 45-60%, however the 30 second interval load drops still happen regardless of load itself being lower than 100%.

The 30 second intervals seem very weird to me as well. However I do not experience this in any other game than MSFS. And the 30 second intervals are consistent. I’ve loaded up a flight and had my plane sitting at the airport for 30 minutes and the 30 second intervals persisted through the whole 30 minutes. (I did this test as I was thinking maybe it was downloading scenery and adding to the world or something and that was the cause of the stutters, but no, that was not the case as it seems).

I’m at a complete loss.

This may be a total shot in the dark, and I only mention this because I recall having similar issues with Battlefield games… are you running a Gigabyte motherboard and it’s bundled software by any chance?

If so, do you have the “EasyTune” and/or “EasyTune Service” running? If you do, I suggest uninstalling this. It’s known to cause some really wierd issues with some titles. It took me months to figure out that this was the reason behind the performance issues I was having… as oddly it only affected the Battlefield games, and nothing else.

I guess it goes without saying that even if you don’t have a Gigabyte motherboard, have a look at any similar bundled motherboard/hardware software that you may have running on your computer.

Any manner of these could have updated without your knowledge, and causing these sudden issues you’re seeing… particularly ones that involve power-saving or performance monitoring… and in my experience they can sometimes selectively only affect certain games too, just as you’re experiencing.

A process of elimination. Hopefully you get to the bottom of it!

EDIT: Also have a look at this screenshot… maybe worth seeing if you have this selected…

I have EVGA cards and no software besides Nvidia Geforce Experience.

I’ve set all those settings to Prefer Performance in Nvidia Experience, Control Panel and Windows.

I’m pretty sure this issue must be with MSFS update.

Why else did it start after MSFS update and only seems to happen while in MSFS and no other game?

Super frustrating though.

1 Like

I can not , absolut not :wink: , recommend the usage of nvidia experiance optimizations…

You should disable in Geforce Experience the Auto-Optimization and RESET the former Optimization. Same within Nvidia Controll Panel => Reset to Default. Then use in-game settings only.

EDIT: beside of these are some existing thread about Pauses ( and/or Stutters )

Already done.

Issue still persists.

Used proper driver uninstall software to cleanse old drivers before reinstalling newest driver.

I’ve done literally everything that can be done as far as GPU settings, game graphics and connectivity settings, resolutions, frame rate caps, vsync, refresh rates, updating drivers (windows, gpu, microsoft store etc), turning off firewalls and antivirus, running just 1 GPU at a time and in SLI, running MSFS in microscopic 640 pixel resolution in windowed mode (which cuts GPU load to like 35%) but still get stutters every 30 seconds.

And this stuttering every 30 seconds only happens in MSFS.
And it only happens after UK update.

In 600 hours of play since launch I have not had any issues whatsoever with the game, but after UK update, stutters every 30 seconds nomatter what I do.

At this point I have given up on the game entirely. It’s literally unplayable with the 30 second stutters and there is nothing I can do on my end anymore.

All I can do is not play and hope they fix it in some future MSFS update.

Extremely frustrating.

you have some special kind of hardware ? … or VR hardware incl. installed drivers ?
or some additional software is runnig ?

I think I may have found the solution, awkward as it might be.

Today I did two things.

  1. Plugged my keyboard (G19) into a different USB port.
  2. Went to the WIndows Power Management (where you can set high performance mode) and changed the USB Power Suspend setting to “DISABLED”.

Ran the game and suddenly no more stutters.

So it seems it was the USB that for some reason caused this. No idea what made that start though. But now I have 3 different flights and flown for about 4 hours total and no issues so far.

the old windows 2004 issue is back ?.. or have you an older windows-version ?

But I though about such an issue, because the description smells like a period disconned of devices and MSFS nees some seconds in this case ( itt freeze ).
Some users have this issue with bluetooth devices which goes into sleep mode.

Nope.

Turned on PC today, log into MSFS, same issue.

I give up.

some users reported issues wiht the logitech game software… possible close it for a test, if you have it running ( I have the older?? “Logitech Gaming Software in v9.02.65” running without issues )

Already updated Logitech and ran driver remover tools to clear old drivers.

No change.

Even started it with no USB connected at all except mouse and keyboard.

And not sure why that would be an issue now when I flown for 600 hours with no issue until now.

bug within the app is of course allways possible.

But I ask me why others not notice these 30 seconds. Therefore I think about possible reasons :slight_smile:

Same issue. Started to happen after the UK update. Someone mentioned opening the VFR map to kickstart the GPU usage back to 100%

the exact same 30 seconds ?

That part is not the same. The drop to zero starts a little further in flight for me . Perhaps 20 to 30 mins… but once it starts its persistent and its recurring. Once i bring up the VFR map and zoom in and out a bit it seems to correct itself and usage goes back to 99. So if its exactly every 30 seconds for you maybe its something else ?

not for me, but for OP :slight_smile: ( see first post image )

I’ve done some more looking.

Do you happen to have Discord installed? (https://devtrackers.gg/hyper-scape/p/95a2f2a9-frametime-spikes-stutter-every-30-seconds-on-the-dot)

1 Like

Yes, I have Discord installed.

Attempted the suggestion of uninstalling discord and deleting the folders.

Restarted the PC and then started MSFS.

Same issue persists. Stutters every 30 seconds.

Maybe it’s not discord then but something else, but I am clueless as to what. I haven’t installed anything new lately.