Game freezing when trying to load in a flight

I don’t usually have problems with the simulator. If so I have always tried to reinstall it and it had always worked. But now I’ve tries that 3 times. 2 times on Microsoft and 1 on steam. Yes I made a dumb choice to buy it on both. Well to the problem. I can log in to the game very good like I used to. But when I try to spawn a plane in a random airport it freezes when I am at around 80% of loading. I know that it takes around 2 min to get in, but I’ve waited 20 minutes and it still didnt load in. I went into the task manager and it said Microsoft Flight Simulator Not Responding. Someone said that if I had installed Google maps version I should remove some text from the Hosts file in File Explorer, well it didn’t work. This happens every plane and every airport I try. Help!

Remove the Hosts file altogether.
Restart PC.
Window’s will make a new one.

Large complex airliners do take 10 or more minutes to load for the first time.

If the issue still exists, start with this troubleshooter:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.