Game hangs on startup, stuck on black screen

Does anyone else have an issue where the game will not actually startup to even get to the loading screen that is giving everyone else problems? I run the app and all i get is a black screen, a 3-4 second loading circle in the bottom right corner that goes away. The app is running in the background but it’s just a black screen. I’ve tried running as an admin, tried uninstalling and reinstalling, tried turning off my AV (Defender), rebooting, running in windowed mode. Nothing makes a difference. Hoping there is some solution out there as right now i can’t even get to the initial screen to begin the content download.

1 Like

Unplug all USB devices but your keyboard and Mouse. Seems to do the trick here.

No Doesn’t do it. Still stuck on Press a key to start. Very frustrating

I had to uninstall everything!!! Do all my windows updates and then magically it could get to the download screen again…waiting to install AGAIN…I had 20 minutes of a working simulator and then screen froze and I got the black screen from then on in…

Good suggestion but nope that didn’t do the trick, still stuck on the black screen.

Try to change your Sound Output to your Monitor.
I had the same Issue, solved in another Topic

4 Likes

But then i have to play the game with the sound coming out of my monitor?

1 Like

nah switch Ingame to the Output you want to use,
thats the way it works for me atm… Will get fix soon for sure

2 Likes

I had the same issue, tried uninstalling the game, cleaning the Store cache, nothing worked.
Then I did three things at the same time so I don’t know what exactly fixed, but the things were:

  • disabled real-time protection from Windows Defender
  • disabled Firewall
  • connected a headphone on my audio port (until that moment I had no audio device plugged on the computer)

After that, launched the game and started downloading.

I’ve uninstalled and reinstalled, but still gets stuck or takes a very long time to load.

This is crazy I can’t believe that worked. Changing the sound output, how could that possibly be the conflict? Well thanks for the fix even if I have to switch audio outputs every time.

3 Likes

I’ve tried all of this tips, still not working. spent 12 hours soon trying to play this s… game. now its getting on my nerves. :sweat_smile:

1 Like

Sound output might be the issue then, amongst the stuff I unplugged there was a dongle for my wireless headset.

2 Likes

any other solution?

I’m on a laptop, is there any other way to solve this other than changing sound to monitor?

1 Like

This worked for me as well. Changed the sound output to my headphones instead of desktop speakers and it loaded right up. Weird. Thanks for posting.

1 Like

confirming aswell the audio thing worked for me. WTF they should fix that thing and conflict

Maybe it’s related to the audio on the motherboard?

#Motherboard: Asus ROG Strix X570-F (Sennheiser game one plugged on the motherboard)
Monitor: ASUS PG258Q (audio working on there right now)

other hardware and prolly non relevant components on this issue:
ryzen 3700x
Corsair rams
SSD from samsung.

Solved my issue by changing the name of my user folder, it had a non english character in it. It is so disappointing to encounter encoding errors in titles like this.

I fixed it by spamming my left mouse button, idk if that was the thing that fixed it, but I’m just happy I got the game back

Disconnect all USB devices etc then try loading and adding one by one to fix black screen issue.
After a 9hr download and buggy install I finally got the sim to load. The next day I could not get the sim to load, all I got was the black screen. After reading this thread I disconnected my USB Soundcard and now it loads every time so to get sound I re-connect after the sim loads. Once the bugs are fixed this will be awesome, looks and fly’s amazingly!