Game license cannot be authenticated

Any solution yet because now I don’t see anybody or a maximum of 2 to 6 players I called my isp the send a mechanic changed my modem did all sort of diagnostic and there is no problem at my end

Happening now for the last couple of hours. Earlier today everything was peachy keen. Haven’t changed anything on my end.

That is an article that is directed at PC, but I have the constant problem on Xbox X, only after purchasing “Premium Deluxe”.

I have filed a bug report here (again). I have tried previously to get ZenDesk to notice this ongoing, repeating issue, but they are 100% dismissive and not helpful. Also, I believe it is related, if not similar to, the current Azure cache issue. At very least MSFS on Xbox:

  1. can not reliably contact the ‘notary’ servers for validation each time it launches
  2. fails to detect that in fact the internet itself is connected and every other services works
  3. has no graceful fallback to allow play when MSFS has worked even the previous day
  4. message still blames the user
  5. fails to detect the properly installed offline files, etc.

Here is a link to the Xbox troubleshooter.

At the end of the article are link to several other lists that may help.
as well, if it is related to a corrupt save, this link may help.

1 Like

TheSevenflyer, thank you for the links, I’ve done all that (and more), and it makes no difference. It’s obviously a server issue (because it affects multiple users, who had no problem the day before, and with no changes on the user’s side). Even if I get it connected today, it will happen again in the next few days - this has been the pattern since I made the purchase in November.

But more importantly, I don’t think my message is being heard - I’m trying very hard to demonstrate that the WAY MSFS behaves when the validation (notary) server can’t be reached, is 100% wrong, and the logic, messaging, and behaviour still need to be fixed. I’m on standard Xbox X hardware with no customization - and if this happens to me with “Premium Deluxe” software, it will happen to others as well.

Here are the issues that really do need attention:

  1. When MSFS is launched, it asks a ‘notary server’ to test the validity of the licence. ALL software does this, including Microsoft 365, etc. I did not have a problem with this when I was just using the GamePass subscription and the basic version of MSFS. As soon as I PURCHASED MSFS 40th Anniversary Edition, Premium Deluxe, I started having this issue. I made the purchase in the last week of November, 2022, so like 10 weeks ago. Since then, I - and others on this forum - have tried to grapple with the error. It is OBVIOUSLY a server issue - and as we have seen in the past 2 weeks, Azure servers DO have issues sometimes, and they take time to find and fix… I have no problem with that.
  2. MSFS advertises that it allows OFFLINE play - however, if MSFS starts up and is unable to reach the licence validation server - it chokes, instead of having proper fallback logic. It fails to detect properly installed Offline World Data files. It fails to recognize that all other online servers and services are reachable and functioning normally. It then fails to allow use of the software.
  3. When I have taken the time to document and report these above issues to this forum, and to ZenDesk, neither the forum staff nor ZenDesk have any visibility in to server issues - but instead of offering to escalate to someone at Microsoft to look in to the issue, the ticket is just closed without any fix or resolution.
  4. What is maybe worst about all of this, is that when the process breaks, Microsoft and Asobo have no idea - the logic tells the user they are offline or they aren’t signed in, but instead it should be notifying MS / Asobo that the validation server can’t be reached even when other servers can be reached… MS / Asobo can only go to Azure to request a fix if they have that data.

So again, I really need to communicate this: my issue is not with servers going offline - my complaint is about how MSFS behaves when that server is offline, and that the connection errors need to be reported TO MS/Asobo every instance so they can request fixes from the Azure team.

It is not supposed to lock you out of MSFS, it is supposed to allow offline use. Only the MSFS developers can fix the logic and behaviour of what happens WHEN a server can’t be reached (whether it is the MS Marketplace programmers, or Asobo, I don’t know).

And, ZenDesk is the only official channel to ask for official technical support - and honestly, all they seem to want to do is close tickets regardless of whether they are resolved or not. I’ve submitted a handful of tickets to them, none are resolved, but all are closed.

My only other recourse is to write a letter to Jorg, Seb, Martial, and if need be, to go to management. I am a Microsoft customer outside of Xbox and MSFS, I manage several hundred corporate accounts with various levels of Microsoft service - and whenever there is an issue of software not working, I am able to get fairly realiable support. But not for MSFS.


my game is standard edition and my mistake,i get the free G5000 of Premium Deluxe edition in AAU1 in MarketPlace.i delete it and the Game License still cannot be authticatde.

PC or Xbox?

Well, not getting the game license errors right now but definitely suffering from the effects - there’s no server available since almost 24hrs. What is the issue? Why can’t I get into the game?


I am doing a full 100% factory reset today, on MSFS and Xbox X. I will document every single step to demonstrate to Asobo / MS / Azure / ZenDesk / Forum moderators, that there is a chronic server issue with relation to Xbox X and MSFS 40th Premium Deluxe - and that the MSFS behaviour WHEN there is a server issue is not acceptable.


After a full factory reset of Xbox X, and clean, new install of MSFS 40th Anniversary Edition Premium Deluxe, all set up as new, following the generic set up screens… the first screen I get is this:

So, it’s defintiely not working as it should. The fact that Xbox recognized the valid purchase in my account, and installed 129 GB in 35 minutes, means both my account and my internet connection are completely fine. Here is the full story, with full step-by-step details of today’s factory reset:

1 Like

I am experiencing a similar or possibly worse situation. I have had the authentication error for thirteen days with no resolution in sight and unable to even start MSFS. I have reinstalled MSFS at least three times and performed a full Windows 10 re-install which proved to be a complete waste of time. The only thing I have not tried but still considering is to delete MS Store/Xbox account and re-create a new account as if from a new human with a fresh new purchase of MSFS Deluxe at another 100 bucks. A professional PC associate told me he has a customer do just this and much to his chagrin, MSFS would still not start. MS/Xbox support is practically hopeless as is this entire sorry mess. I just got off the phone for the third time with Xbox Support who can not help and simply refer the customer to the forums.

I think that they are aware. I would not delete your MS / Xbox account - it is up to MS / Asobo / Azure to solve this, not up to customers. The past 2 weeks have seen some pretty serious Azure server issues, and I think MSFS is just a victim of that… However, MS / Asobo ALSO need to fix the behaviour of how MSFS behaves when there are specific network issues, and, how it reports errors back to MS / Asobo… instead of just the current “assume the customer is doing something wrong” attitude.

I’m remaining polite and optimistic at this point, and if there is no formal acknowledgement, I will take this to the Microsoft Management level - but I don’t think I’ll have to go that far. It might take time, but once Jorg, Seb, and Martial are actually made aware of this issue - that it is a direct problem for sales - they will figure it out and fix it.

Bug report link above … the forum seems to rank everything by “votes”.


Thank you very much for the information and advice. Sorry, but I don’t see where to vote.

Click on the link to the bug report in my post a few posts up … on that page go to the top and click Vote

Done; thanks again.

1 Like

Great - thanks, and I think they will fix it. The forum staff have limited information and access and it takes much more effort than it should to get a real issue noticed. But never forget that you are a paying customer of a trilliion dollar company for an advertised product - if this forum can’t help, I personally would not hesitate to write an actual letter (with documenation) to Jorg Neumann, head of MSFS c/o Microsoft HQ.

Thanks for that info. I think it imperative to maintain the focus and ramp up the urgency. I would really like to know how many people are affected.

1 Like

I have now connected a Wireshark to the Xbox to capture all traffic for analysis.

In testing, I have booted Xbox and opened MSFS about 6 times, and 3 times it actually did open properly connected (for the first time in a week), and 3 times it failed to do so with inconsistent error messages - so I think they might actually be working on it.

I’m not an expert at packet inspection, but if anyone else is, let me know.

Due to the abnormality of the activation server in Singapore, the IP cannot be pinged, so some users cannot connect to the authentication server normally.
To solve this problem, add in the hosts file

Has any recent progress been made?
I’m on day 16 being completely locked out of MSFS with zero progress. Thankful for X-Plane 12.