Game not responding when I try to start

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. Removed. Folder empty.

Are you using Developer Mode or made changes in it? No

Brief description of the issue: I’ve tried to start the game today to download the new UK update and the game just isn’t responding on load. I don’t even get to the Asobo logo. Just black screen with frozen loading wheel bottom right. CTRL+ALT+DEL and task manager says game not responding so end task. But in Steam the game says it is still running. Not even got to the point where i can download the update. I was playing it two days ago and all was fine. So i’m certain it must be associated with the update today. Game is being powered through Steam. Any help appreciated to avoid me having to reinstall the entire game.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered: Double click icon from desktop. That’s it. Game freezes on load about 30 seconds in.

PC specs for those who want to assist (if not entered in your profile)

Did you submit this to Zendesk? If so, what is your ticket #? No. Don’t know how.

Low-hanging fruit - empty your Community folder of any Mods, reboot the PC and retry.

Done but still the issue is there. I removed all mods from the community folder and restarted as my first effort. I’ve gone through a checklist of Steam troubleshoots but to no avail. Repaired folders, cleared download cache and verified the integrity of installed files. All are fine. Will try updating my Geforce driver next.

Um, by verifying files (a Steam eccentricity), you’re forcing a complete re-download of the sim. Like as if you’d never downloaded it before. That may or may not matter now, given the problems, but you should probably know.

Had similar issue, my flightsim did not even start.

Steps that helped me.

  1. I’ve removed xbox app, removed all related msfs content (msfs uninstall, manualy removed all files left).
  2. PC restart
  3. Download xbox app
  4. Run installation from xbox app(there was a bug that total size was 150GB instead of 1.4gb installer)
  5. Moved to store, i’ve checked that msfs luncher is installed.
  6. Run msfs from ms store
  7. Nothing happend
  8. Closed and opened xbox app → run msfs from xbox app
  9. Sim has started and i’m downloading full content right now, it’s seems that it works well now.

Maybe you can do something similar.

Thanks for the advice. Will that work for games purchased through Steam though? That’s where I bought my copy.

I have no idea. Try to make the most fresh install as possible. Of course you will wait for those 150gb to be downloaded but it’s still better to wait one day instead of waiting week or more for fix/solution :wink:

So I also have the steam version, and since release, have experienced issues where every say…2/10 times? I launch the game, it just never loads.

I also get similar behavior in steam where it thinks the game is running.

So far, I’ve not looked into the issue, as the CTDs and random freezes are far more problematic, but I wanted to say that you’re not the only person dealing with this unreliable start-up.

You could reinstall the game, but I want to emphasize that this may or may not fix the problem. Generally I’m of the opinion that any problem that “requires” a game reinstall indicates something is very broken with the game, and is something Asobo/Microsoft needs to fix - to onus is NOT on you to mess around with your computer to get the game running. full stop.

Your best bet, in addition to any trouble-shooting tips people on forum give you is:

2 Additional Suggestions

  • Startup of applications like games can be hindered by other apps running in the background.
  • Zendesk (see the support link at the top of the forums) has some “Support Articles” with handy tips for things you can tinker with to get the game running. I can’t speak to their efficacy, but they are worth a try.

Have a look and what else you have running (in the background), and try disabling/turning off those temporarily (including antivirus like windows defender), ONE AT A TIME (so you know what worked and what didn’t work) and then try launching the game over and over and see if your results change (yep, it’s tedious).

If you pin down a background app that seems to be mucking things up, report it to zendesk too, as this is something that needs to be fixed if possible.

Good luck to you.

Thanks for all your responses. It looks as though the issue was embarrassingly straightforward! My anti-virus software was blocking the game from loading, so it just kept freezing. For some reason my antivirus had detected a change in the game. I think it was when Steam installed a MS VC direct package, which itself was possibly in response to a Windows update behind the scenes (C++ package updates from what I can make out). But for some reason my antivirus didn’t prompt me to permit MSFS interact access from desktop. I had to open AV software and then straightaway i was asked for permission. Unfortunately due to me taking various other steps trying to resolve it i;ve had to reinstall the whole game which i’m in the middle of now!