Game not starting? (Microsoft Edition)

It would do the loading animation on the lower right corner then after that you’re stuck with a black screen, I’ve waited at least an hour giving it a chance to load.

This did happen after I updated to the latest version, and to try and isolate the issue I removed the mods I had to see if it would start on it own state but with no luck.

In a situation like this, I would always open the Task Manager (Ctrl+Shift+Esc) to see what the computer is doing. This lets you see if the internet is busy, it there’s a dialog waiting for your input, if your discs/CPU/GPU are overloaded etc.

There are many suggestions on the forum about how other people have solved similar problems, unfortumately due to various very different causes. It may just be a question of trying each in turn.

I’m having the same issue tonight. CPU almost idle, no disk / network traffic. Guessing something related to the new version being deployed tomorrow?


My PC is normal status when I start the game, the game is using about 500MB to 1GB of Ram, CPU is about 10 - 40% usage in short bursts, GPU is Idle, and Internet has no activity.

I tried uninstall and reinstall
turn off PC and On again
Check drivers for updates

I’ll pretty much wait for the update.

Good to know there’s an update on the way, It doesn’t really bother me too much since I didn’t bought the game it just came with game pass that I got when I purchased an Xbox controller.

I’m waiting till next year to see how it progresses before I buy it.

The idea is to use the task manager once the black screen appears and the computer hangs. As you say, the computer is behaving normally before starting the game, but what is it doing at this point - is it repeatedly accessing the disc drive, or the internet, or has it posted a Windows error message hidden behind the black screen, or is the CPU busy doing nothing?

The update will certainly change some files, and stands a good chance of unblocking the problem, so please let us know what happens. And I hope you like it enough to buy it outright - I’ve been buying flight sims for about forty years, and of all the “games” I’ve had, the flight sims are always what I come back to, both for entertainment and education.

I’m also having this issue. The start-up will get to about 80-85% on the blue bar and just hang. It started last night and I’ve tried all sorts of combinations of removing community content, removing navigraph, uninstalling purchased sceneries, etc. to try and isolate the issue. Based on other posts in this and other forums, it seems many are able to use the program, so what’s happening here?

Anyway, looking forward to tomorrow’s update, but any feedback on this issue would be great.


I still haven’t been able to get MSFS to load. It’s been working perfectly for me up until yesterday. Right after launching I get the black screen shown below with the spinning “waiting” icon. This never comes back.

I see no CPU, GPU, disk, or internet activity
I have nothing in my communities folder
Nothing has changed on my PC

Any ideas? Two days now and haven’t been able to launch MSFS. Opening a ticket with Zendesk but I already know they’ll just say to reinstall the program.

Tried looking for any startup logs or something - anyone know if anything like this is logged anywhere?

Getting frustrated!


Actually, after leaving it to sit for 15 or 20 minutes, it eventually popped up a windows firewall dialog. After turning that on, I made it to the screen showing devil’s tower, where it’s also sitting there not moving forward. Other people are having this issue also:

I’m going to try the cache delete that’s being called out to see if it helps. As mentioned above I don’t have any mods in my community folder. I’ll report back how it goes.


And just to close the loop on this…I did indeed end up doing a full uninstall / reinstall, now everything is working properly.

Wish I knew what went wrong!

Here’s what it looks like after opening it with Task Manager acitivity

Again I’ve done uninstall and reinstall, I also followed steps in Zendesk but that’s what happens. It seems to be launching an update launcher but it disappears and launch the game instead but I am not sure.

I would totally buy this in the future 100% just not right now because of its current state, I fell in love the aviation world when I first messed around with FS2004.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.