Gaming Service issue - Again - it's an absolute disaster

That’s about what I faced during the month I tried to get MSFS to load back when I bought it in 2020. I contacted MS, they failed to help me and eventually sent me to XBox. XBox failed to help and eventually sent me to Asobo/Zendesk where the issue could be logged, filed, and ignored.

An update was pushed - Friday I believe - to version 3.64.20001.0: you can install that through the MS Store using “Updates” in the Store app. You might try that to see if it helps. If not, then perhaps resort to the method I outlined in my linked post.

I agree that is pretty crazy to have to resort to using Powershell. The majority of users will not know how - or want - to use it. Pretty convoluted, but it does work.

Windows 10 - latest stable version (gaming services)


Works without any problems.

I went through all available troubleshooting steps, including removing and reinstalling Gaming Service, XBOX app, repairing gaming service etc.
Microsoft support extended the offer to refund the cost of FS2020, but I want to get the silly and annoying issue with the underlying OS service fixed.

I am now afraid that MS has no solution, the whole system of Xbox + Gaming service + MSFS + Win 11 is out of control. Hence the refund offer. At the moment I only see the possibility to install MSFS again via STEAM. But I’m not sure whether there are new pitfalls lurking.

Bad idea.
Reset your PC

@Arekitect66 already mentioned that resetting the PC works for a few days before the issue returns. I’m also in the same boat where Gaming Services stopped working. Even resetting the PC doesn’t help. It will solve the issue for a few weeks before it returns.

No, sorry, that’s not a bad idea from MS but a honest and logic reaction. It’s a clear admission that they can’t solve the problem. Full stop.
I initially considered your solution recipes to be very competent, but I had to realize that, like so many other recipes here, they simply don’t work either for me.
You can’t get real control over the Gaming Service behavior. It is unpredictable because it depends on many factors which vary from PC to PC. That is precisely the problem we are talking about here. It is a multifunctional problem that has outgrown MS. I can’t even be angry anymore, just resigned.

@StrohSchema7980 Do you mind if I ask what processor/system you are using? I’m curious to see if the Gaming Services issue is just a Microsoft issue or if it is something to do with the processor/system.
PS. I have an Alienware R10 with a Ryzen 7 processor

Another 2 hours with Xbox support to be eventually transferred to Windows Tech Support, only to find out that they DO NOT provide support for individual services. The only option is to reinstall the OS or repair and blow away all apps and settings. Do they have any idea how ridiculous this sounds?
It takes hours to reinstall Windows and all apps and I’m not planning on doing this for the 4th time this year.
I do share the frustration of everyone else suffering from this glitch, as it takes the pleasure away from the reason we purchased FS2020 - and that is to relax and enjoy something we are deeply passionate about. Reinstalling Windows is NOT that!
I’ve been working in Enterprise IT for over 25 years, and the level of ignorance and poor customer service on Microsoft’s part in handling this bug is surreal.

How is the bad idea to get a full refund, and reinstall software using Steam, which magically always works?

1 Like

Which version of Windows operating system are you using?

The latest build of Win 11Pro

Yes, I have planned that now. I wrote a letter to Zendesk and described the misery and my anger.
And I asked for a refund of the purchase price (DVD box premium deluxe). As soon as I have the money (I doubt it) I will make one last attempt and buy and install the program through STEAM.
By the way, the term “Premium deluxe” is pure mockery. Already during the first installation I got an impression of what to expect later. After installing all 10 DVDs I ended up in the MS Store and didn’t know what to do here. No hint, no guidance. It has remained so to this day.

I thought you said your sim was now working?

Yes, for the moment, because I reinstalled everything from scratch. For the second time in 5 months.
The Gaming Service blocker comes out of the blue, completely unpredictable. Why can I assume this won’t happen a 3rd time soon? If the STEAM installation is also causing this trouble, then I forget MSFS. When the trouble is greater than the fun, it’s time to stop.

As far as I know the only “fix” necessary was to either update Gaming Services to the latest version available, or follow the procedure to forcibly remove it, then re-install it.

There shouldn’t be a need to remove the sim or re-install the OS.

Please learn, that I’ve tried almost everything published here. No success.
Especially procedures via Powershell which manipulate registry entries:

“Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServices” –Recurse”
“Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServicesNet” –Recurse”
“get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers”

Of course I tried everything before I had to make the big cut.
What else could I’ve done?

Windows 11? - not recommended for simmers. Which version?

I wonder, why it’s not recommended? Do you mind elaborating?